1. Exquinoxx's Avatar
    Whenever i use in my Droid Turbo they'll work for about 2-3 months hen stop all of a sudden. They will continue to work in all other devices just stop in my phone. However if i put a new pair in they work fine but same thing happens.
    01-05-2017 09:38 AM
  2. PowrDroid's Avatar
    Whenever i use in my Droid Turbo they'll work for about 2-3 months hen stop all of a sudden. They will continue to work in all other devices just stop in my phone. However if i put a new pair in they work fine but same thing happens.
    This has happened to me. Make sure there is no lint crammed down inside the headphone jack. Hold the phone upside down and use a toothpick to fish out any lint or else use a can of compressed air with a straw tube attached to the nozzle to remove any lint.
    01-05-2017 09:49 AM
  3. Exquinoxx's Avatar
    Didn't work
    01-05-2017 09:59 AM
  4. Exquinoxx's Avatar
    Any other suggestions?
    01-05-2017 10:39 AM
  5. PowrDroid's Avatar
    I suppose you've already tried this but...

    With the headphone jack inserted in the phone and content playing, rotate the inserted headphone jack, lightly wiggle it, or otherwise slightly change the position of the jack within the phone's headphone jack. The idea is to see if you get any sound at all. If you do, it would indicate that there is something in the headphone jack interfering with a good connection.

    When I had this problem, at first glance I thought I had cleaned out the headphone jack receptacle. But I kept at it and found some junk in there and cleaned it out.
    01-05-2017 11:32 AM
  6. zen45's Avatar
    I had the same problem with the power plug, I would turn it off and plug it in at night and it would do that little vibration before shutting down and pop out , in the morning it would look almost plugged in and not charged using a tooth pick I kept at it and finally out popped a piece of lint . keeping the phone in your pocket is just a lint trap in all the small openings .
    01-05-2017 01:32 PM
  7. nedqadams's Avatar
    I've had the same thing but only one ear will work. I've since just moved on to wireless because I couldn't find a reliable way to make sure they were both active.
    I've also noticed my Turbo has difficulty charging. Cables will work for a few days and then I need to swap them out and they jiggle in place. Never had that problem before with numerous microusb phones.
    01-12-2017 04:17 PM

Similar Threads

  1. Motorola Droid Turbo 2 doesn't start anymore
    By AC Question in forum Ask a Question
    Replies: 4
    Last Post: 01-15-2017, 01:47 PM
  2. My Droid Turbo by Motorola stuck on No Command
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-06-2017, 08:11 AM
  3. Rotation issues:
    By Wmlaveck in forum Ask a Question
    Replies: 2
    Last Post: 01-05-2017, 11:01 PM
  4. Replies: 2
    Last Post: 01-05-2017, 09:41 AM
  5. Replies: 0
    Last Post: 01-05-2017, 03:33 AM
LINK TO POST COPIED TO CLIPBOARD