1. xxjdogxx71's Avatar
    I recently bought a droid ultra and i know it supports Tmobile bands. I popped in a new nano sim i bought from Tmobile and i updated the vpn settings and switched to global networks, but now i can seem to get any data service. I had Edge working for a minute but that was as far as i could get and it didnt stay on very long. Now im stuck without data. Anyone have any ideas why?
    03-25-2015 07:49 PM
  2. itguyjax8430's Avatar
    I recently bought a droid ultra and i know it supports Tmobile bands. I popped in a new nano sim i bought from Tmobile and i updated the vpn settings and switched to global networks, but now i can seem to get any data service. I had Edge working for a minute but that was as far as i could get and it didnt stay on very long. Now im stuck without data. Anyone have any ideas why?
    First, go into your mobile network settings and change to LTE/UTMS/GSM.
    Second, change your (Select Network) to GSM only.
    Third, create an APN that is as follows: NAME;T-Mobile,
    APN; epc. tmobile. com,
    MMSC; ht tp:// mms . msg. eng. t-mobile . com/mms/wapenc .
    APN Type; default, mms, supl
    APN Protocol; ip4/ip6.
    Leave everything else alone.
    03-25-2015 09:03 PM
  3. xxjdogxx71's Avatar
    First, go into your mobile network settings and change to LTE/UTMS/GSM.
    Second, change your (Select Network) to GSM only.
    Third, create an APN that is as follows: NAME;T-Mobile,
    APN; epc. tmobile. com,
    MMSC; ht tp:// mms . msg. eng. t-mobile . com/mms/wapenc .
    APN Type; default, mms, supl
    APN Protocol; ip4/ip6.
    Leave everything else alone.
    Thanks for your help! I realized I forgot the dash in the T-Mobile name and I put it in and it fixed it.

    Posted via the XT1080
    03-25-2015 09:05 PM
  4. itguyjax8430's Avatar
    Awesome glad I could help.
    03-25-2015 09:49 PM
  5. KipLektrik's Avatar
    I had the same problem recently and I'll tell you what worked for me on my Droid Ultra XT1080, because it's a little different than the answer given.

    Preferred network type: LTE/CDMA
    APN: fast.t-mobile.c*m (this won't let me post links)
    MMSC: h*tp://mms.msg.eng.t-mobile.com/mms/wapenc
    APN type: default, supl, mms

    I, too, was only getting pathetic Edge speeds, even after changing the APN. What worked was checking the LTE/CDMA type, which seemed to FORCE it away from GSM (LTE/GSM/UMTS) and onto LTE.

    4G LTE popped in immediately.
    I hope this helps any other Droid brothers or sisters.
    09-09-2015 04:44 PM
  6. 1cdninoh's Avatar
    I'm having the same problems.
    Although I've tried both config's (above) I still get no 4G, LTE or data on my Ultra.
    Hope there's something else I could try. Really like the phone.
    Thanks.
    Alex
    10-02-2015 10:57 AM
  7. 1cdninoh's Avatar
    Got it!
    Thanks all.
    Alex
    Name: T-Mobile US LTE
    APN: fast.t-mobile
    MMSC: htt^p://mms.msg.eng.t-mobile.com.mms.wapenc (note that I intended to type '.com/mms/wapenc but mistyped as shown)
    APN: default,mms,supl
    APN Protocal: ipv6
    all others left in default condition
    10-02-2015 02:07 PM

Similar Threads

  1. Why is my phone so slow on home wifi?
    By michael632 in forum Samsung Galaxy Note 4
    Replies: 13
    Last Post: 12-29-2017, 01:26 PM
  2. Sugar water spilled over Galaxy S3, how can I fix this?
    By Mhx8 in forum General Help and How To
    Replies: 3
    Last Post: 03-25-2015, 09:48 PM
  3. What is the effect of clear data on the Facebook ap?
    By AC Question in forum Android Apps
    Replies: 2
    Last Post: 03-25-2015, 09:13 PM
  4. How do I disable receiving e-mails on my Galaxy S 5?
    By AC Question in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 03-25-2015, 08:37 PM
  5. Replies: 1
    Last Post: 03-25-2015, 07:24 PM
LINK TO POST COPIED TO CLIPBOARD