1. Explicit's Avatar
    I'm posting this only because I've seen this question asked numerous times even by myself. I spent a few days here and there on different forums hoping to find this resolved, but never did. After a Friday night to Santa Cruz to watch a couple bands playing (yes I'm from Nor Cal) and while I kind of knew where this place they were playing was at, after not being in Santa Cruz for 4 years I had forgotten. Put on my GPS and it took 15 minutes to get a lock on my location. On FroYo it would take me seconds to get a lock on my location, but 15 minutes was horrendous. After contemplating if I really needed the functionality of the GPS which I don't always use, I decided even if I don't use it this function should work no matter what. So my 4 hour search began to scourer forum after forum. Finally on the last place I decided to look, the Motorola forums, my answer was found.


    https://market.android.com/details?i...=search_result

    GPS Status & Toolbox was the answer to this problem. I found the solution at this link:https://supportforums.motorola.com/t...677?tstart=150 with the person who posted the instructions on what to do.

    I had this problem and I found a fix! I used GPS Status & Toolbox by EclipSim.
    Menu - tools - manage a-gps state
    I did a reset followed by a download

    Now my GPS is getting a fix very quickly again!
    Hopefully everyone with this issue see's this and it works for them. Just want to help out fellow Droid X owners as well as Android users in general.
    jahoobob and bmderuosi like this.
    07-20-2011 10:57 PM
  2. topgunz1's Avatar
    I tried this last night with no luck, even after a reboot. Just tested it again and it worked instantly without resetting the a-gps.
    07-21-2011 02:28 AM
  3. Explicit's Avatar
    Weird cause since I've done this fix, it has worked every time. I did read that you should reset and then redownload the satellite info every 3 days or so. Whenever I use the GPS I make sure to do this since I'm never constantly using this feature on a daily basis.
    07-21-2011 09:58 AM
LINK TO POST COPIED TO CLIPBOARD