1. mpgo4th's Avatar
    I bought a used X off ebay. The manufacture date is 08/2011. I contacted verizon and they said using the meid number it has no warrenty. My screen has red pixil in the middle and sometimes my media volume doesnt work unless I pull the battery and reboot. Will motorola warrenty the phone or am I SOL?
    09-07-2011 09:21 AM
  2. kismet769's Avatar
    You're probably SOL since its past the year warranty. Moto might replace it, but they'll have you send it in so they can troubleshoot it.
    09-07-2011 12:46 PM
  3. rsxtcy4me's Avatar
    I'm guessing SOL too...

    Sent from my DROIDX using Tapatalk
    09-07-2011 12:51 PM
  4. mpgo4th's Avatar
    oh, is that 08/11 the warrenty end date. I thought it was the build date. I rebooted my phone by pulling the battery and everything works now but that tiny red dot is driving me crazy. Come on bionic!!
    09-07-2011 12:59 PM
  5. Ahowe125's Avatar
    oh, is that 08/11 the warrenty end date. I thought it was the build date. I rebooted my phone by pulling the battery and everything works now but that tiny red dot is driving me crazy. Come on bionic!!
    No I believe that to be the build date. I purchased mine late in February 2011 and my date is "03/11". So they must date it ahead a little to anticipate it sitting in inventory a little bit.

    I would assume you still have the 1 year manufacturer warranty, but getting Verizon to help you out could be harder since you did not buy the phone directly through them.

    Maybe you could contact Motorola directly and see if they are willing to do anything for you.
    09-07-2011 01:24 PM
  6. mpgo4th's Avatar
    Tried calling moto today. No number listed on their website and the live chat took forever and still noone responded. Oh well.
    09-07-2011 07:55 PM
  7. mpgo4th's Avatar
    Got to talk to moto CS today and they were very helpful. He is sending me a box with prepaid shipping and promissed a 5-7 day turn around for free repair. He told me I had warrenty until 12/16/11, while VZW said it was out. What the hell is VZW's problem with great coverage and crappy cs?
    09-08-2011 01:19 PM
  8. Ahowe125's Avatar
    Got to talk to moto CS today and they were very helpful. He is sending me a box with prepaid shipping and promissed a 5-7 day turn around for free repair. He told me I had warrenty until 12/16/11, while VZW said it was out. What the hell is VZW's problem with great coverage and crappy cs?
    Kinda interesting that you only have coverage until 12/11 when we assume the sticker indicated it was made 08/11. This would mean it only had 4 months of factory warranty. Maybe that date is not when it was manufactured?

    Either way, glad they decided to help you out and fix your device. Do you have a backup? If not I would go talk to Verizon and see if they will give you a loaner phone. Just explain to them that your getting yours fixed by Motorola, maybe they will be nice and help you out.
    09-08-2011 05:34 PM
  9. mpgo4th's Avatar
    Yes I activated my old blackberry bold for the time being. I kind of like using it again.
    09-09-2011 08:44 AM
  10. rsxtcy4me's Avatar
    Yes I activated my old blackberry bold for the time being. I kind of like using it again.
    The bold was a good phone when it worked. I had one, it broke, verizon switched me over to the droid x. I liked the bold while it lasted though..

    Sent from my DROIDX using Tapatalk
    09-09-2011 03:23 PM
  11. ndreher's Avatar
    Yes I activated my old blackberry bold for the time being. I kind of like using it again.
    I miss my Blackberry at times as well.

    Typing is the biggest thing I miss.
    09-09-2011 09:17 PM
  12. vicw926a4's Avatar
    I believe the dates on the DX represent the Week/Year, rather than Month/Year.

    That is pretty typical, and might explain how the manufacturing date could be misinterpreted to appear to be later than the current date.

    Sent from my DROIDX using Tapatalk
    09-11-2011 08:18 AM
  13. mpgo4th's Avatar
    thanks, that makes sence. I have fixed the reboot and media volume problem. I want through and uninstalled ALL apps that I dont use everyday. I think it was bunny shooter that caused the reboots but I have no way to tell now that they are all gone. The phone has run perfect for three days now so Im calling it fixed. I still have a red pixal in the lower middle of the screen that is visable on dark pages but not light or white ones like websites. Im thinking of just not sending it in for repair because its in such good shape, Im scared it will come back worse. Am I crazy for not wanting to be without it for 5-7 days???
    09-12-2011 09:38 AM
LINK TO POST COPIED TO CLIPBOARD