1. revwill's Avatar
    For the last two days GMail has not been pushing to my X. I don't know why. None of the suggestions I can find by using the search function on the forums is helping.

    Is this happening to anyone else? Any suggestions?
    09-02-2010 01:44 PM
  2. jemalone's Avatar
    I just checked an I have not had anything come into my gmail account on my Droid X since aug 18. I have two email showing up when I browse to gmail on my computer that do not show up on the phone. Not sure why its not updating on they phone either.
    09-02-2010 02:03 PM
  3. jthacker's Avatar
    I've been having some issues with Gmail push as well...I wonder if it's specific to the X or if it's Gmail's servers in general that are having problems?

    Edit: Just to clarify...I'm still receiving emails but I'm noticing skipped messages and significant delays in receiving notification of emails...also noticing the same for google talk/gchat.
    09-02-2010 02:13 PM
  4. Arelunde's Avatar
    Check your email settings on the X and make sure you have the "data push" enabled (checked) and a short interval for "fetch" such as every hour. If push isn't possible, the fetch schedule will kick in. Also make sure you don't have "sync only over wi-fi only" enabled, unless that's what you want.

    gmail>settings>email delivery>data push/fetch schedule/sync over wi-fi only

    Also, check in the regular settings to be sure the sync gmail is enabled...

    settings>accounts>gmail>sync gmail (check)

    I have my gmail account set up to collect email from my 2 pop3 email accounts and deliver it all to my X on a push basis. Works fine. Also, when this is done, if you delete either on your desktop gmail or X, the email is deleted on both (need to remember this when deleting from the X).

    Also, gmail doesn't push the spam, which keeps your X from getting inundated with junk email. I love that!
    09-02-2010 03:04 PM
  5. revwill's Avatar
    I gave 'er the old Factory Reset and all is well. I think the settings may have gotten messed up when I tried out Launcher Pro or a couple of other applications a few days ago.

    Oddly enough, I went back to Blur. I kind of like it.
    09-02-2010 03:26 PM
LINK TO POST COPIED TO CLIPBOARD