1. debob's Avatar
    After installing 2.2 my DX is no longer recognized by the computer. It comes up as MB810 but the adb drivers are missing and I can no longer browse through it like I could on 2.1.


    When i try to install the adb drivers it comes up with an error as well.

    I'm on 64 bit Win 7
    09-22-2010 11:50 AM
  2. debob's Avatar
    anyone? bump
    09-22-2010 12:17 PM
  3. slater's Avatar
    Same issue on win xp pro sp3 32 bit
    09-22-2010 12:55 PM
  4. debob's Avatar
    someone?
    09-22-2010 02:27 PM
  5. cmakar's Avatar
    I found that you have to turn off the USB debugging mode that pops up on the phone OR the phone will not show the device as a hard drive. Just did this and it worked right away. It only shows the micro SD card and then a CD Drive called Motorola which looks like it might be teathering from Motorola - I am on Windows 7 64bit as well. I am wondering is there a way for me to see the onboard drive / memory on the phone somehow? Anyone know? give it a try and let me know.
    09-22-2010 02:37 PM
  6. debob's Avatar
    This is what I'm talking about



    It worked right up until the point that I installed 2.2 and now nothing happens. Everytime I try to install the drivers I get errors...

    Just curious as to why not that many other people have this problem.
    09-22-2010 02:49 PM
  7. debob's Avatar
    Found this on a random post via a google search:

    "When you put the phone in charge only mode the driver in device manager will change from that B810 (which I couldn’t get a driver for either) to adb interface go in to the adb interface and right click to update driver it will ask if you want to search automatically or choose from a list you want to chose from a list , adb mot composite, something like that there is only one that sounds like that but update to that one it may give you a message saying it is not recommended or w Pphat ever but just click yes anyway it should say drivers updated successfully and voila good luck need more help"
    09-22-2010 02:55 PM
  8. bloodoak's Avatar
    Not sure debob, I have win 7 64 bit as well and I have never managed to get the drivers to load properly for adb. even using the driver files that have been posted on various websites, the adb composite driver is never recognized by my system. I would like to know the answer to this as well.
    09-22-2010 02:56 PM
  9. debob's Avatar
    Not sure debob, I have win 7 64 bit as well and I have never managed to get the drivers to load properly for adb. even using the driver files that have been posted on various websites, the adb composite driver is never recognized by my system. I would like to know the answer to this as well.
    the steps i tried about worked out well for me. I can now get my phone to come up with the "adb devices" command.
    bloodoak likes this.
    09-22-2010 03:07 PM
  10. bloodoak's Avatar
    I'll give that a shot when I get home tonight, thanks. Has driven me nuts that I can't get adb to work, even when I was on 2.1
    09-22-2010 03:24 PM
  11. slater's Avatar
    Try this (credit goes to Baracuda2 who I thanked in the How to Root 2.2 offical Thread, Thank him there on page 3 if it works.)

    http://forum.androidcentral.com/moto...tml#post357210

    If you are having trouble getting the ADB driver installed, try the latest from the Motorola site. Motorola_Mobile_Drivers_4.7.1_MotoConnect_1.1.31.

    My previous 4.6 drivers weren't working for OTA froyo on the phone before rooting.

    http://forum.androidcentral.com/moto...tml#post357210
    09-22-2010 03:33 PM
  12. xelhabb's Avatar
    Check out Droid Life board, ADB will NOT work with official 2.2.
    09-22-2010 03:37 PM
  13. doctorlove316's Avatar
    Check out Droid Life board, ADB will NOT work with official 2.2.
    ADB DID work with the official 2.2 and DOES work. That's how people are rooting.
    09-22-2010 04:41 PM
  14. debob's Avatar
    Check out Droid Life board, ADB will NOT work with official 2.2.
    Yeah I got mine to connect but never got root. I had to go to class by the time I got it working and didn't have time to type all the commands.

    I think it does actually work though.
    09-22-2010 09:02 PM
  15. slater's Avatar
    Check out Droid Life board, ADB will NOT work with official 2.2.
    Please view my previous post...it is possible and does work
    09-22-2010 09:05 PM
  16. wildman's Avatar
    Please view my previous post...it is possible and does work
    I just connect to device in storage mode and I then copied the driver off unit.. its included in app for Motorola embedded in rom.

    09-22-2010 09:52 PM
  17. debob's Avatar
    I just connect to device in storage mode and I then copied the driver off unit.. its included in app for Motorola embedded in rom.
    Do you mean that you let it install automatically or what? I did the same but it just sat there and failed to install the drivers. so....i dunno.


    I think I am going to wait to root anyways until an SBF file is out. That way I can flash back to stock 2.2 if something goes wrong.
    09-22-2010 09:55 PM
  18. debob's Avatar
    This is what i get with mass storage mode:

    09-22-2010 10:04 PM
LINK TO POST COPIED TO CLIPBOARD