1. draftpeppin's Avatar
    Just wanted to post some findings here in case it helps anyone. I saw some other posts on this, but they are quite old and didn't seem to get solved.

    On my Droid X, approximately since I got the official 2.2 Froyo update from Verizon, I noticed that my location wasn't being updated when Maps was running in the background. I observed this from Latitude on my laptop.

    I've been trying a few different things to fix this, without success, until today.

    As far as I can tell, all I did today was I turned off Use wireless networks, then turned it back on (hoping it would refresh some settings), then turned on Enable Assisted GPS (which I had previously turned off, thinking it was killing my battery). After that, it seemed to start updating again, first every few minutes, then hourly. Previously, it would go a day or more and not update until I had Maps active on my screen.

    I then turned the Assisted GPS back off. It still seems to be updating regularly now. I'm kinda kicking myself for not playing with the "Use Wireless Networks" and "Assisted GPS" settings separately because now I won't know for sure whether toggling one of those or both of those fixed it. In any case, at this point, I have Wireless and GPS on, and assisted GPS off, which is how I had it set when there was a problem. So, toggling seems to have updated something.

    Hope this helps others further diagnose similar issues.
    09-26-2010 03:17 PM
LINK TO POST COPIED TO CLIPBOARD