1. pivaska's Avatar
    I don't see anyone on the forums that have actually connected a Droid X using 2.2 (froyo) to their Enterprise Exchange server. Is there anyone that is using a Droid X (froyo) in a business environment without any problems? We have a 2003 server but we are upgrading it to 2010.
    Thanks in advance
    10-04-2010 10:24 AM
  2. quic's Avatar
    works fine for me.
    10-04-2010 10:38 AM
  3. zep's Avatar
    I had issues when I first got my phone but it is working great now.

    I had to make sure the "Include Inheritable Permissions..." check box was checked within AD for my account.
    10-04-2010 10:47 AM
  4. madlaw1071's Avatar
    I downloaded Touchdown from the Market. Works perfectly and adds enhanced features like task synching.
    10-04-2010 11:31 AM
  5. miamifin33's Avatar
    I have to use Touchdown or else Exchange does not work for me. I find it ridiculous that it's necessary to use a 3rd party app in order to have Exchange support, but what do I know...
    10-04-2010 11:34 AM
  6. chrisb3's Avatar
    Works fine for me. Have several users on both 2.1 & 2.2 (including my X on 2.2) with no issues. We're using Exchange 2007 in the office.

    As long as the ActiveSync for Exchange is on (that's an add-on through a patch in 2003) you should be ok.
    10-04-2010 01:56 PM
  7. t9giese's Avatar
    I have mailboxes on both exchange 2003 and 2010. Both work great. There were problems with 2003 not showing in the notification bar on 2.1 but that is now fixed.
    10-04-2010 03:33 PM
  8. LordBlackmore's Avatar
    I finally updated to 2.2 this past weekend and our corporate exchange works fine with touchdown and the corporate sync application.
    10-04-2010 05:22 PM
  9. Se7enth Sinn's Avatar
    I have both but I don't use touchdown anymore, the UI looks way too like a windows 98 app.
    10-04-2010 08:18 PM
  10. liquidhonesty's Avatar
    Works fine for me...Exchange 2007. Try unchecking the option that makes you use https....might help with older exchange servers
    10-04-2010 08:42 PM