1. Dural's Avatar
    The Droid X WiFi connect bug has been an issue for some. For me, I am unable to connect to my g/n Netgear router unless I power cycle the router, in which case my X connects immediately. Otherwise, my X will enter a constant loop of checking for IP address, connecting and then disconnecting. This is one of the few (if only) issues I've experienced with Froyo. On v.2.1, I never expereinced this issue.

    There's a strong possibility that the new update will address this bug. In the interim, I've fixed the problem for me (and my Netgear router) at least.

    Change your router wireless setting to broadcast g only; no auto, and no b/g or b/g/n. The instant I changed it to g only via online login, my X auto detected and then connected and now does so perfectly and automatically. Again, its late in the game since the update (which will likely be released today) will probably make the issue moot, but this sure will help me capture the update before the OTA broadcast! Do the following to force the update, once available:

    1) Turn on WiFi. Leave it on. If you check for an update now, it will likely still say "none available at this time"
    2) Do a normal power cycle on your X.
    3) The update should pop up on reboot with WiFi on. If not, check for updates and it will pop up then.

    Hope this helps some enjoy fewer WiFi connect issues and faster access to the update.
    speednut likes this.
    12-07-2010 12:20 PM
  2. JkdJedi's Avatar
    Thanks for the heads up. I heard about this switching to G instead of mixed to speed things up. I did it and have noticed considerable differences. Especially with my Roku which is set up on wifi. (And yes the X hooks up a little quicker ) ;-)

    Sent from my DROIDX using Tapatalk
    12-07-2010 12:51 PM
  3. NewAge's Avatar
    I had heard this earlier and tried to much success. I have had no wifi issues since.
    12-07-2010 01:47 PM
  4. Dural's Avatar
    Very kind of the good folks here at AC to link this to the front page. Hope it helps some alleviate any ongoing frustration before the new Froyo update for the X.

    12-07-2010 06:34 PM
  5. andrewcweaver's Avatar
    having problems too. It will connect, but it won't last.
    12-07-2010 08:04 PM
  6. speednut's Avatar
    @Dural - Thanks, that did the trick and fixed this issue for me. I appreciate you sharing this info with us!
    12-08-2010 01:45 AM
  7. nedqadams's Avatar
    Is the update working for people with these problems?
    12-08-2010 04:09 AM
  8. Mudvayne622's Avatar
    Ok I knew about switching to G only months ago and it does work. The real problem lies in the fact that the DX doesnt stay connected. It constantly drops connection. This is true for 2.1, 2.2(froyo) and as of now still the same on 2.2.1(froyo+1). Sad really that Moto couldnt figure this one out.
    12-08-2010 07:21 AM
  9. Dural's Avatar
    @Mudvayne. Can't say I've ever experienced that problem, and now that I switched to g only, my X stays connected until I turn the connection off. Interested if he update will/will not address the issue you're mentioning.

    Edit: Some good signs that the update addresses WiFi issues on early returns:

    12-08-2010 02:18 PM
  10. carb850's Avatar
    My X wouldn't connect to my modem which doesn't have 'N' capability. I found a fix.

    Per phraupach of another forum.
    "The problem you are describing might be related to this Google bug 8804:
    Issue 8804 - android - wpa_supplicant 0.6.10 (froyo) unable to auth in a wpa2/enterpise wifi - Project Hosting on Google Code
    The problem does not happen with all routers/access-points, but it is a bug in Froyo 2.2.
    The fix is already done, but it wasn't included in 2.2. Perhaps Motorola can get it in there and push out an update.
    A workaround is to use WPA 1 only, disable WPA2 and 802.1x if possible. Corporate or university networks probably won't be able to do this."

    Changing to WPA only solved my issue.
    12-08-2010 08:16 PM
  11. PeterPhan's Avatar
    My X won't stay connected to my Linksys WRTG router no matter what I've tried. So sick of this,,one of the reasons I bought it was to use WiFi...argggggggghhhhhhhhhh!
    12-13-2010 04:12 PM
  12. Neil DeBoer's Avatar
    Had a wifi disconnect issue and found that my Battery Saver app was the culprit. Probably an update as it worked fine until recently. Set the Battery Saver app to NOT turn off the wifi and problem resolved.
    07-04-2013 02:15 PM
  13. Robert Barber's Avatar
    This worked for my droid x2. Change the DHCP setting on your router to anything but forever. Forever seems to be thee default setting.
    01-09-2014 09:33 AM