1. TwoEyes's Avatar
    I have an iMac with a complete address book and calendar that I keep up to date. I tried syncing with Google using SyncMate so that I can then see all the info on my DroidX. Every time I try, I end up seeing the address fields listed twice (or more) in Google. Sometimes I end up with combined entries when some family names are similar but are different people. When I first started, my Mac address book and calendar would also end up duplicated. I tried deleting everything in Google then used a saved Mac address book and only had the Mac sync with Google one way to Google. I still end up getting duplicates within entries and combining people. Anyone with similar problems and how did you fix it? It's so frustrating to me that I may break down and just get an iPhone on Verizon before my contract expires on my DroidX. I love the Droid otherwise.
    01-29-2011 05:26 PM
  2. irish22022's Avatar
    whoa whoa... don't go the iphone route just yet! First things first, you should try google's sync options, not third party stuff.

    Google Sync Services

    I did that with mine right when I got the droidx, and I was good to go from there. If that doesn't work, you'll need to export all of your contacts from address book to vcard (under the file tab), then import to google from gmail contacts.

    If that doesn't work, post back with issues.
    01-29-2011 09:51 PM
  3. Arelunde's Avatar
    I can't count the number of times I've written this advice, but it's all too true...

    Be very suspicious of the auto-backup from Verizon. Even if you don't activate it, it will still store your contact list on the My Verizon website and sync with Google's data. You will end up with multiple duplicates, links and old data.

    Answer - Go onto the My Verizon website (log in to your own account), go to the contacts list and DELETE THEM ALL. This will not affect your Gmail contacts list - it's all backed up by Google. However, it WILL eliminate all the mess. After you're done, click the sync contacts in Settings > accounts > Gmail. Should be a vast improvement.

    If there are still some issues remaining, you might have to do as Irish suggests ... delete your Gmail contacts list, export from your iMac and re-import them to Gmail.

    I learned this the very hard way ... via Factory Data Reset and having to clean up my contacts list by hand. Best of luck!
    01-30-2011 12:36 AM
  4. Arelunde's Avatar
    PS - It's a good idea to check the My Verizon contacts list periodically, deleting whatever is listed there. If you don't, sooner or later, you will end up (again) with a mess on your X.
    01-30-2011 12:37 AM
  5. azmo's Avatar
    Interesting. I am going to have to check that out.


    Sent from my DROIDX using Tapatalk
    01-30-2011 02:29 PM