1. gordol's Avatar
    I need help in figuring out and fixing this issue. Whenever I plug my Droid X into my PC the Droid crashes, but apparently not all the way as the Uptime is not reset. D-X is running os 2.2.1, PC is running Win7 HP x64. I'm using a 32GB MicroSD from Kingston, which is currently about half full with photos.

    What specifically happens is that I plug it into a powered USB hub and almost immediately it does a reboot, which only takes about a half minute. When it comes back up, Windows Explorer shows me the Droid's internal memory as a CD drive mapped to G:, with the Moto icon, and the MicroSD card is mapped to L:, but not mounted. At this point, I can unplug it and plug it back in and it works as it should, internal mapped to G: and the card shows fine mapped to L:.

    Since this problem started, I've added and removed too many things and settings for me to remember what changed between when it worked and when it broke.

    I don't know how relevant this is: I'm using Widgitsoid configured to put the toggles in the Notification area, but changing its config or totally removing it (and rebooting) makes no difference. Using or not using other power control widgets has not made any difference either. I am also using Advanced Task Killer Free.

    What other information is needed to try to nail this down?
    02-06-2011 11:41 AM
  2. cryogenic's Avatar
    At least in my case, while running the Liberty ROM, disabling USB Debugging fixed the problem for me. If you don't already have it on, then I'm not sure what else you could try.
    02-06-2011 07:31 PM
  3. dwaynewilliams#WN's Avatar
    I have the same issue. I'm running stock Froyo w/ the micro SD that came with the phone. I use Windows XP. But my Droid X continues to reboot when I plug it in with the usb cable. Like the OP said, it stops after the first time.
    02-07-2011 12:09 PM
  4. mikesmith's Avatar
    Mine does the same thing when I plug it in and change it to USB mass storage. If I leave it as charge only then it doesn't restart.

    Stock Froyo on WinXP computer.
    02-07-2011 12:55 PM
  5. Ricky Babalu's Avatar
    The first thing I would do is: Rule out the sd card, might be defective. Either reformat card or try one that you know is good.
    02-07-2011 01:15 PM
  6. stacyadell's Avatar
    It may sound basic, but what helped me eliminate this problem which I sometimes have when I switch from charge only mode to USB mass storage mode to prevent my X from rebooting is to slide from screen to screen when I plug in and then when I switch modes.
    02-07-2011 05:22 PM
  7. gordol's Avatar
    I'm using the stock firmware from Google via Verizon. "Debug USB" is not enabled.

    I found a work-around that seems to be working (2 out of 2 tests): Unmount the MicroSD before plugging into the desktop and re-mounting it once the Droid is seen by Windows.

    I would rather find a solution, though.
    02-07-2011 09:30 PM
  8. Arelunde's Avatar
    You DO have to have you X in USB mass storage mode to have it seen as a flash drive by your computer. The option to select this appears in the notification pull-down panel as soon as you plug it in. Also, if you have a password protection on, the X will not be seen by your computer until after you log in.

    BTW ... do NOT install that very annoying and lame Moto app on your computer -- the one that wants to install each time you plug in your X via USB. It's useless and only muddies the waters. A direct USB/flash drive type connection is totally sufficient. Works perfectly. Just hit cancel each time anything about the Moto program wants to start up.
    02-08-2011 12:05 PM
  9. cryogenic's Avatar
    Try installing alogcat out of the market. Start it up, make sure it's tailing your logs correctly. Plug the phone in and watch the logs. See what happens. That should give you a good idea as to what's causing the issue. They're pretty standard linux log messages, so if you don't quite understand what's going on, post them here and we'll see if we can help (I'm a regular linux user myself).
    02-11-2011 10:28 AM
  10. dcusick1's Avatar
    Same thing here. I've seen this issue reported before. For me, and a lot of others, this started happening after the Froyo update. I was fine before the update, and then when I updated to Froyo, this happens consistently. Basically, I download a show I record daily on my home PC via dropbox. I cannot access dropbox at work, so I download as it records via dropbox on my DX. After I get an hour or so of recording, I copy it to my PC, so I can drop it on my ipod. The first time I connect my DX, it reboots. I have to pull the plug out and wait for it to come back up. When it boots up, I plug it in, and it works fine. Then, I start my download process again for the next hour. And again, when I plug it in the first time, it reboots. This is VERY VERY frustrating to deal with.
    02-11-2011 02:07 PM
  11. juergen99's Avatar
    I just got an X yesterday and have been having the same problems. My original Droid didn't have this issue. Since yesterday I have tried so many combinations of settings and PCs that my head is spinning. I have got it to work but then the next time it doesn't. I hope we can find a solution to this because I used my Droid as a mass storage device almost on a daily basis.
    02-11-2011 02:11 PM
  12. mikesmith's Avatar
    Uninstalled the Moto driver and hit cancel when it tries to install it and it still crashes.

    Then I have to unplug, plug back in, and it finally works.
    02-15-2011 07:30 PM
  13. wildman's Avatar
    Download and install Motorola_Mobile_Drivers_4.7.1_MotoConnect_1.1.31.exe from Motorola_Mobile_Drivers_4.7.1_MotoConnect_1.1.31.exe, new version removed this option...

    Once the installation has completed you can go into your Control Panel/Programs and Features area and uninstall JUST the MotoConnect application from the list and leave the drivers installed.

    This should install all drivers needed to the system without having the MotoConnect app installed and you should be able to access card without issues and copy any type of file you want to the sd card.

    Follow installation process listed above and then follow instruction here.

    It appears that the main issue that cause the driver loading issue is a conflicting driver already installed at time the correct driver is loaded but the old driver wasnt being uninstall automatically, if you or any one run into this issue again the trick is to open the Motorola Driver Installer.exe that is in startmenu under Motorola folder and select the "CLEAN AND REINSTALL" option from app and select start and all old drivers will uninstall and the correct drivers will be loaded... I was able to duplicate the driver install issue twice and both times I was able to fix with these instructions..

    Hope this resolves user driver and SD Card access installation issue
    02-15-2011 07:56 PM
  14. dwaynewilliams#WN's Avatar
    I deleted LPP and the rebooting when connected to the PC in mass storage mode stopped.
    02-17-2011 04:26 PM
  15. wildman's Avatar
    I deleted LPP and the rebooting when connected to the PC in mass storage mode stopped.
    Good to hear, LLP has became a real issue lately, I suggest trying ADW Ex. I have up on LLP when this was released and I do not regret it. LLP is still nice a nice app but it has to many issues lately,
    02-17-2011 05:35 PM
  16. greydarrah's Avatar
    ADW is a great option, but I did read a post where someone uninstalled LPP, battery pulled then reinstalled it and the fc's and reboots did not return. I'm not pimping LPP, but as a user of it, it's not that think it's the greatest UI, I would just hate the idea of having to set up all of my home screens. icons and what not in another app. In mind mind (and it's a very tiny one), it almost seems as much trouble as a factory reset.
    02-17-2011 06:46 PM
  17. wildman's Avatar
    I understand but it only took about 10 or 15 minutes to set my LLP layout onto ADW, but its your decision.
    02-17-2011 11:02 PM
  18. gordol's Avatar
    This issue appears to have been resolved with the Gingerbread update. It no longer crashes when plugging into the PC, but it does make a notification noise despite being set not to.
    07-02-2011 01:07 AM