1. wormeyman's Avatar

    I can see it on the market and it says purchased in my webbrowser but when i go to the market on my phone it is gone and it is not listed in my installed apps nor is it listed in my settings-applications either.
    02-09-2011 12:12 AM
  2. tntdroid's Avatar
    How about this free one.

    Sent from my DROIDX using Tapatalk
    02-09-2011 09:44 AM
  3. wormeyman's Avatar
    i'm actually kindof a tetris nerd and i prefer the real version with the TTC rules. and whoah read the comments on the game apparently i'm not the only person that cannot find the game in the market nor re-download it!
    02-09-2011 02:39 PM
  4. jfiguraMT's Avatar
    Mine disappeared completely from my phone. I went to market.android.com and found it in my list of purchases. I went to click on it to install and it says "Not available on your carrier" (Verizon) but it is available to my Alltel phone.

    Something fishy going on.
    02-09-2011 06:10 PM
  5. wormeyman's Avatar
    jfigura i'm glad to know that i am not the only one, this is so weird!
    02-09-2011 06:25 PM
  6. El Jefe's Avatar
    I play my Tetris on NESoid...no app needed.
    02-09-2011 06:40 PM
  7. jfiguraMT's Avatar
    Unable to re-download purchased EA Games apps from Android Market when I replaced damaged phone - Android Market Help

    It's apparently some kind of Market/EA issue. Some people bought for 99 cents. I bought mine at 2.99. I still The Sims on my phone but Tetris went bye bye. I think it has to do with the way EA has listed it in the market at their latest price which cuts off people who bought it when it was on sale.
    02-09-2011 06:46 PM
  8. jfiguraMT's Avatar
    I fired up my Alltel phone and the only EA games on the market there are The Sims and Fifa. Tetris and Monopoly not available.

    Went to Market online and looked up "Worms". Tried to buy it. Not available on my carrier... Who knows where the real issue is at this point.
    02-09-2011 06:59 PM
  9. hkklife's Avatar
    Having the same problem here. Performed a hard reset to clear up some lingering DX issues and I'm unable to DL any of the EA games I bought on sale other than the Sims. I seem to recall hearing about Gameloft doing something this a while back for the one title they sell in the Market. I think they changed the name of the game slightly or their publisher name and locked out anyone who bought it early from being able to redownload it or receive any updates. Google REALLY needs to police the Market more closely and clobber these crooks when they try this sort of stuff.

    Years ago, way back in the old Palm OS days, I kept a list of the titles I had purchased that had been abandoned in an unreasonable amount of time or whose publishers refused to let you have a new Device ID or change to a new Hotsync ID. I periodically thanked developers such as SplashData and Astraware that went the extra mile to offer support after the sale, especially for registration/update/installation issues. Sad to say that I may have to revive my old "publisher blacklist" for Android devs :-(
    02-10-2011 01:14 AM
  10. alphabets's Avatar
    yep its an EA issue. and apparantly only is happening to anyone who got the games when they were .99. i bought sims 3, nfs, and tetris. for some reason sims 3 shows up as installed but the other 2 do not. hopefully its fixed soon.
    02-10-2011 08:22 AM
  11. wormeyman's Avatar
    I bought tetris for $5.31 this is so weird!
    02-10-2011 10:49 AM
  12. broadwayblues's Avatar
    EA issue with how the app was listed in the marketplace. I think that you have to just sit it out while they figure out what they did wrong.
    02-10-2011 12:12 PM
  13. wormeyman's Avatar
    i've tried contacting customer service and the email bounces back telling me to use the website, and the website won't load once i login!
    02-10-2011 01:35 PM
  14. LMO's Avatar
    So do you have a Titanium Backup (or similar backup) of it that you can just reinstall the .apk?
    02-10-2011 02:58 PM
  15. jfiguraMT's Avatar
    Titanium backup wont work. When you fire up the app it tells you your device isnt authorized. At least thats what happened to me. Instead I have flagged it twice in the market explaining the issue and hoping that Google will get it fixed.
    02-10-2011 03:10 PM
  16. stacyadell's Avatar
    I bought the game for the .99 special and having no problems with the game, email me at sdellorfano@gmail.com
    02-10-2011 04:26 PM
  17. wormeyman's Avatar

    it appears that there are at least 2 versions of tetris i'm guessing that EA just doesn't understand the android market and keeps re-naming their app?

    also can anyone else not login when they hit contact us http://support.eamobile.com/ i even registered a new ea account!
    02-12-2011 04:06 PM

Tags for this Thread