1. CarSalesman's Avatar
    How can I turn off the Verizon radio, but keep Bluetooth and Wifi on? Airplane mode kills the wifi.
    03-07-2011 09:03 PM
  2. Dirty Ders's Avatar
    Do you want both 2G and 3G off? Or do you want just 3G off?
    03-07-2011 09:12 PM
  3. Dirty Ders's Avatar
    1) To get rid of both 2G and 3G then go to settings>wireless & networks>check airplane mode> check Wi-Fi mode. Done. Now you only have Wi-Fi. Works the same way for Bluetooth.

    2) If you still want 2G on and only use Wi-Fi for Data then settings>Data Delivery>uncheck Background Data>uncheck data enable. Then back out twice to settings>wireless networks>check Wi-Fi. Done.

    Or, go to the market and download some widgets, then just click the airplane widget before the Wi-Fi widget and your done.

    All that works for me. Don't know why it works or why your allowed to do that being in airplane mode and all, but it works.
    03-07-2011 09:26 PM
  4. WAldenIV's Avatar
    Widgetsoid will allow you to toggle 2G, 3G, wifi and more.
    03-07-2011 09:59 PM
  5. CarSalesman's Avatar
    I want to turn off 2G/3G/Voice in areas where Wifi is available, but Verizon isn't. That might be in a vehicle or building where Verizon is n/a, or even on some aircraft where wifi is provided. When the Verizon signal is n/a, the phone will use a lot of power trying to find it.

    I looked at Widgetsoid, that is a big tool for what I am looking for. The reviews are mixed from "wonderful" to "it doesn't work". I may try that, are there any alternatives? Seems odd that the Motorola-supplied widgets or Android settings menu allows you to turn on/off bluetooth, gps, wifi, but not WAAN?
    03-08-2011 06:45 AM
  6. WAldenIV's Avatar
    I want to turn off 2G/3G/Voice in areas where Wifi is available, but Verizon isn't. That might be in a vehicle or building where Verizon is n/a, or even on some aircraft where wifi is provided. When the Verizon signal is n/a, the phone will use a lot of power trying to find it.

    I looked at Widgetsoid, that is a big tool for what I am looking for. The reviews are mixed from "wonderful" to "it doesn't work". I may try that, are there any alternatives? Seems odd that the Motorola-supplied widgets or Android settings menu allows you to turn on/off bluetooth, gps, wifi, but not WAAN?
    I bet most people that complain about Widgetsoid failed to read the update instructions. Some of the earlier updates required the application to be uninstalled before updating. Also, when it is updated, it is a good idea to create a new widget to ensure proper functionality.
    03-08-2011 10:57 AM
  7. racinwarrior's Avatar
    download quicksettings
    03-08-2011 11:15 AM
  8. Dirty Ders's Avatar
    I want to turn off 2G/3G/Voice in areas where Wifi is available, but Verizon isn't. That might be in a vehicle or building where Verizon is n/a, or even on some aircraft where wifi is provided. When the Verizon signal is n/a, the phone will use a lot of power trying to find it.

    I looked at Widgetsoid, that is a big tool for what I am looking for. The reviews are mixed from "wonderful" to "it doesn't work". I may try that, are there any alternatives? Seems odd that the Motorola-supplied widgets or Android settings menu allows you to turn on/off bluetooth, gps, wifi, but not WAAN?
    1) To get rid of both 2G and 3G then go to settings>wireless & networks>check airplane mode> check Wi-Fi mode. Done. Now you only have Wi-Fi. Works the same way for Bluetooth.

    2) If you still want 2G on and only use Wi-Fi for Data then settings>Data Delivery>uncheck Background Data>uncheck data enable. Then back out twice to settings>wireless networks>check Wi-Fi. Done.

    Or, go to the market and download some widgets, then just click the airplane widget before the Wi-Fi widget and your done.

    All that works for me. Don't know why it works or why your allowed to do that being in airplane mode and all, but it works.
    WAN, uses Wi-Fi (unless I am mistaken) just like PAN/MAN… it is the Wi-Fi transceiver radio that is doing the communication.

    You should be able to do everything you want by following my instructions. You don’t need widgets or third party apps (even though they will make it easier), you just have to turn on airplane mode before you turn Wi-Fi back on.

    Say you are in an area that has 2G (Voice) coverage but doesn’t have 3G (Data) coverage; use the second step.

    If you are in an area that doesn’t have either 2G or 3G; then use the first step.
    03-08-2011 03:03 PM
  9. sniffs's Avatar
    Put into airplane mode and then manually turn on wifi.\

    PS. Verizon doesn't have 2G. Their entire network is 3G and you cannot turn 3G off like you can on some GSM devices(AT&T/Tmobile)
    03-08-2011 03:39 PM
  10. Dirty Ders's Avatar
    Verizon doesn’t have 2G? WHAT!?!

    Then what do you call their 115Kbps service? 3G.1? I guess that would be accurate and call EV-DO Rev A: 3G.2 I guess it is just semantics.

    If Verizon didn’t have 2G then how did they stay afloat for so many years before 3G came around? Why are there still coverage areas without 3G support but can still support phone calls and very slow data?
    03-08-2011 06:07 PM
  11. moosc's Avatar
    its 1x service but u cant just toggle between 1x and 3g. motorola has a widget its airplane mode u turn it of click wifi and if u want turn bt back. and there are Motorola widgets for wifi and bt. as for widgdroid i have the app and love it no issues.
    03-08-2011 06:25 PM
  12. Dirty Ders's Avatar
    It all comes down to the phone really and what the phone broadcasts at. EV-DO rev A is not an always on connection unlike EV-DO rev 0. Rev 0 is always in contact with your phone while EV-DO rev A is on demand from the phone or network.
    03-08-2011 06:29 PM
  13. Dirty Ders's Avatar
    The Droid X only uses 3G (EV-DO rev A) for data, if you turn off data then you are turning off 3G. The Droid X only uses 2G (EV-DO rev 0) for voice.

    I agree you can't toggle between the two, but you can turn 3G off or turn 3G and 2G off.

    But, everybody is in agreement that all you need to do is go to airplane mode then turn Wi-Fi back on.
    03-08-2011 06:33 PM
  14. CarSalesman's Avatar
    OK guys and gals, as the OP in this thread, I can confirm that airplane mode followed by wifi-on works. Thank you.
    03-08-2011 10:01 PM
LINK TO POST COPIED TO CLIPBOARD