1. Cappurnikus's Avatar
    I updated to the official Gingerbread release and now I can't load any apps from the Amazon App Store. I get the following message when I try:

    "Amazon Appstore: Unknown error

    An error occurred. Please download this app again from the amazon Appstore."

    So I go try to redownload it and get another error:

    "There was an error while downloading ***app. Please try again."

    Has anyone seen this or does anyone have a solution for this problem?

    Thanks!


    EDIT: Rebooted the phone, redownloaded apps and all is well.
    04-13-2011 09:52 AM
  2. Bloodthirsty's Avatar
    Just updated to Gingerbread on my X and now I'm getting a "you do not own this app" message from all apps I had from Amazon. Anybody else?
    06-01-2011 11:32 AM
  3. rrbrambley's Avatar
    Same thing happened to me. Also, I was in the Amazon AppStore and I clicked on the games category, and it told me there was nothing compatible with my device.

    However, after I logged into the forum to reply to your post, I tried again, so that I could type the proper message that it gave me, and now it's working fine. WTF.
    06-01-2011 08:13 PM
  4. ineedanewhandle's Avatar
    Glad I've held off does anyone have amazon app store apps still working?
    06-02-2011 03:47 AM
  5. rgray331975's Avatar
    Mines working fine, but I came from p3droids patch from 595. Don't know if that means anything

    Sent from my DROIDX using Tapatalk
    ineedanewhandle likes this.
    06-02-2011 03:49 AM
  6. Burner50's Avatar
    Mine is working fine... Had some error to re-download, but I rebooted and everything was fine.


    Having no problems with amazon appstore here.


    Was stock Froyo, updated to the "Official" rooted GB
    06-02-2011 12:08 PM
  7. BuMMeR-X's Avatar
    Mines been working fine also, but I had SBFed back before I upgraded and then went and downloaded the AppStore Program and installed it after I got Gingerbread.
    06-02-2011 12:47 PM
  8. nlitenme's Avatar
    Mine's also working fine.

    Was on official Froyo, now on official Gingerbread (no rooting or leaks).

    All I had to do was log back in to the Amazon app & I was good to go.
    06-02-2011 01:13 PM
  9. SouthernSaltine's Avatar
    My Amazon apps work fine... i did have a problem for a day with the Android market not letting me download apps, but amazon works perfect.. Love me some FreeApp"A"Day!
    06-02-2011 03:13 PM
  10. raresuperman's Avatar
    Getting the same message for the DROID bionic as well...they need to fix this missing out in some good stuff....
    09-13-2011 10:27 AM
  11. cron912's Avatar
    I've had issues with Amazon apps several times before, most often after flashing a new ROM. I've fixed it by deregestering and reregestering my device with Amazon. You can deregister a device under 'Your Account' on Amazon's site.

    To do this, you'll need to uninstall all Amazon apps, and the Amazon Android app itself, then deregister the device on their website. Then you can reinstall the Amazon Android app, log in, and download your apps.
    09-13-2011 01:05 PM
LINK TO POST COPIED TO CLIPBOARD