03-02-2014 01:26 AM
38 12
  1. cmkpro81's Avatar
    I have just bought a Milestone X2 from Cspire about 2 weeks ago. And for the past week I have been searching for a way to root my device. And every method has brought me up short I mean try after try no success. Could someone please point me in the rite direction as to where I mite find a way to root my device please. Your efforts would be greatly appreciated. Thank you.
    05-02-2012 09:49 PM
  2. Rustycauley's Avatar
    I'm trying to find a solution to rooting the milestone x2 also. If I can find something that works I'll post the results.
    05-12-2012 03:18 PM
  3. cmkpro81's Avatar
    Hey that will be awesome thanks! And if I find something I will do the same for you.
    JustinL22 likes this.
    05-12-2012 08:05 PM
  4. Rustycauley's Avatar
    I found this link that might work. I haven't tried it yet cause I haven't had time. I might can try it sometime tomorrow. HowTo: Milestone X2 - 2.3.6 Root - xda-developers
    Dick Tater likes this.
    05-13-2012 12:00 AM
  5. cmkpro81's Avatar
    That's the one that I've been having trouble with. I can seem to get past the command prompt part.
    05-13-2012 01:11 AM
  6. chase1212's Avatar
    Has any of these been confirmed to work yet?
    05-17-2012 12:46 PM
  7. cmkpro81's Avatar
    Yes it's works!!!!!! I figured it all out. It was a simple error on my part in the directions that I was following. That method does work but there are 2 versions of that process.
    06-02-2012 04:41 PM
  8. benb4391's Avatar
    Whats the other method? I cant get past the fastboot flash preinstall root.img part!!!! so frustrating
    06-15-2012 11:26 AM
  9. cmkpro81's Avatar
    The method that works is listed above by Rusty. And when you get to that page at the bottom of the last step listed in the root process, there are 2 more links. The one that is marked breifmoblie is the one that did not work for me I may have been doing it wrong I'm not sure. But the one that I used has a few more commands to type in that's the one that I used. Make sure though when you start to follow all the steps to the T. I mean type exactly what you see and press enter after every command. And it will say fail a few times but don't worry just follow the steps. And make for sure that you have yur screen set to not go off. Because that was one of my problems I had cause when it reboots and the screen goes off you will not see the superuser prompt on yur phone and you will miss it and not get root. And make sure when you do start, the files that you do have to download for this need to be saved together and extracted to yur computers OS or on my desktop it was Win7/os. I hope that my trial and error has helped you out I take no credit for the root process itself. It belongs to someone else's hard work and effort.
    06-15-2012 11:13 PM
  10. neonsilverpanda's Avatar
    the links to the adb-fastboot.zip and the other one cant be found
    06-18-2012 02:34 PM
  11. cmkpro81's Avatar
    Try just googleing the 2 downloads that you need. And then go back to the process listed. Im sure there still somewhere on the internet.
    06-21-2012 06:40 AM
  12. Sketch83-54's Avatar
    I have tried that method and I followed all the steps. I didn't see the other commands until i read on into the forum. When i type the last command " PATH=/system/bin:$PATH pm install /preinstall/Superuser.apk" it says installation failed file already exists. In the directions it says you NEED super user installed from the market and it FAILS. Either im not doing something right or my phone is a stubborn one. My phone is also the X2 from C spire. Running 2.3.6
    07-11-2012 08:03 PM
  13. Sketch83-54's Avatar
    could you please explain to me the EXACT steps you used? I would really like to get my phone rooted. (Motorola Milestone X2 from C Spire running2.3.6)
    07-11-2012 08:28 PM
  14. Sketch83-54's Avatar
    SUCCESS. as you mentioned it was a small typing error. Phone its now rooted!!!!!!!

    Sent from my Milestone X2 using Android Central Forums
    07-12-2012 10:43 AM
  15. cmkpro81's Avatar
    Yeah I had the same problem with typing errors I was getting the zeros mixed up with the oo's........ but congrats on yur success and enjoy yur root...

    Sent from my Milestone X2 using Android Central Forums
    07-12-2012 01:22 PM
  16. hightechnoob's Avatar
    Anyone found anything like superoneclick to root 2.3.6?

    Sent from my Milestone X2 using Android Central Forums
    07-24-2012 11:35 AM
  17. hightechnoob's Avatar
    heres a good walk through on rooting x2's BIG thx to XDA!

    Originally Posted by DarkFalconX
    This method works! There are only 2 differences in the commands (indicated in red):

    Obtain the necessary files from the Atrix 2.3.6 link above
    Extract the ADB-Fastboot package and root image to your C:\ Drive under a new folder titled root
    Put your device into Fastboot mode: Turn off your device. Hold down the power button and downward volume button until you see Fastboot on your screen Push the upward volume button
    Connect your phone via USB cable. Allow Windows to install the new hardware if this is the first time you have used Fastboot mode.
    Open your command prompt (Start >> run cmd >> enter)
    Type the following commands
    cd C:/root
    fastboot flash preinstall root.img
    fastboot reboot
    Enable USB debugging (Settings >> Applications >> Debugging)
    Type the following commands
    adb shell
    Allow Superuser access on the phone when prompted
    Type the following commands
    mount -o rw,remount -t ext3 /dev/block/mmcblk0p12 /system
    cp /preinstall/su /system/bin/su
    chmod 6755 /system/bin/su
    PATH=/system/bin:$PATH pm install /preinstall/Superuser.apk

    Congratulations! You are rooted!
    This worked me also but I had to download superuser from the market first then follow the steps, and finally rooted
    07-25-2012 04:21 PM
  18. Sketch83-54's Avatar
    Now if only i could find a good ROM that will be performance enhancing and works on mx2 v. 2.3.6

    Sent from my Milestone X2 using Android Central Forums
    07-29-2012 01:59 AM
  19. Sketch83-54's Avatar
    I heard cyanogen 7 will flash in mx2 2.3.6 but the wifi wont even turn on. I think i heard it on xda or android police. I dont remember. Anywho i just want a nice rom that will STOP THIS PHONE FROM LAGGING. Even WITH setCPU installed running MAX speed, the phone still lags sometimes.......fudge......

    Sent from my Milestone X2 using Android Central Forums
    07-29-2012 02:10 AM
  20. cmkpro81's Avatar
    To get rid of lag you need to delete all the apps that CSpire has on the phone. You know all those sorry apps that nobody wants or uses. And that will free up a lot of space and help with lag.

    Sent from my Milestone X2 using Android Central Forums
    07-29-2012 10:00 AM
  21. Sketch83-54's Avatar
    Where would i find them? Ive tried countless rooting methods and factory reset my phone so many times that i noticed some apps dissappeared.

    Sent from my Milestone X2 using Android Central Forums
    07-29-2012 10:28 AM
  22. dnice155's Avatar
    this isnt actually a reply i just wanted to know if anyone could help me!!!!!! i rooted my phone then i downloaded an app called font changer and i did something in the app changing my font now my phone wont load at all i need help badly plz help someone
    07-29-2012 06:33 PM
  23. cmkpro81's Avatar
    @Sketch the one I use is absolute system tools. And AS Maid pro those will both clean yur phone and delete unwanted apps.

    Sent from my Milestone X2 using Android Central Forums
    08-01-2012 06:45 AM
  24. cmkpro81's Avatar
    Sorry was meant to be SD not ( AS ) DAMN predictive text.

    Sent from my Milestone X2 using Android Central Forums
    08-01-2012 06:47 AM
  25. cmkpro81's Avatar
    @Dnice try retracing yur steps on What you did when you downloaded the fonts and se if you my have changed yur settings by mistake. And if that don't work delete the fonts. Is all I can think of rite now.

    Sent from my Milestone X2 using Android Central Forums
    08-01-2012 06:50 AM
38 12