1. jstkiddn's Avatar
    I hope you guys can be patient and help me out. My ***** son tried to root his phone after I *told* him not to, because I knew he'd screw it up. As usual he didn't listen to his mama and now phone isn't working. I know if he tries to fix it he'll just make it worse, so I'm going to try to see what I can do myself. I'm not a complete moron and can follow directions well, but honestly I know nothing about these phones except using them. I don't know all the abbreviations and lingo, so I need someone to maybe not walk me through this like I'm 5, but maybe like I'm 12. I will bring you up to speed at what I've done so far:

    Have no idea how he attempted to root phone, but I was told that after rooting it worked but then after a short while the touch screen stopped working.

    So far I have:

    1. removed battery and rebooted - nothing, so removed battery/reinstalled again.

    2. Held down power button & vol. down until I saw 'fastboot'; Vol down until I got to Android Recovery; Vol up to select

    3.Get to triangle screen; press vol up and down at same time to bring up menu

    4. Chose 'wipe data/factory reset' and pressed power to select. Scrolled to yes and selected with power button.

    5. See wiping data - Formatting /data; Formatting /cache. See "Data wipe complete".

    6. After complete chose "reboot system now" from menu and select with power button

    7. Cross fingers and make blood sacrifice to the Droid gods

    8. After reboot....touch screen still doesn't work. It gets to the setup screen, you can see incoming calls, etc....but you can't actually answer them because you can't press any 'buttons'.

    Is there hope or do we have a paperweight?

    Thank you very much for any help you can give.
    10-21-2011 06:47 PM
  2. Mr One 2#AC's Avatar
    Try this
    [updated][how-to] sbf tutorial [how-to][updated] - xda-developers

    And quit blaming your kid,u know you did lol. Jk jk.

    On a side note I showed my two sons 13 and 10 how to sbf and root my phone, and let them do it, they both screwed up but I showed them what they did and hoe to fix it. We learn from our mistakes hehehe!
    jstkiddn likes this.
    10-21-2011 11:08 PM
  3. tonysracing's Avatar
    Try this link:

    [updated][how-to] sbf tutorial [how-to][updated] - xda-developers

    This will restore the X2 back to factory settings. I would use the 2.3.4 sbf file. Don't worry about the Froyo or 2.3.3 files. Pay special attention to Step 7.

    EDIT - Mr. One beat me to it!!
    jstkiddn likes this.
    10-21-2011 11:11 PM
  4. jstkiddn's Avatar
    Thanks so much for your help!

    I'm having some trouble though. I *think* I got everything downloaded and I'm at Step 5: Plug your phone into your computer and wait until you see it in RSD Lite and click Start.

    When I plug the phone in I get the windows "installing device" message and then I get some sort of error message stating I don't have the driver se flash daytona.

    What have I done wrong? I'm a little iffy (okay...a lot iffy) on how to properly download and open RSDLite5.3.1_5.1Drivers.rar . Do I just unzip with 7-zip? (which to be honest has me pretty confused as well).

    Sorry to be so obtuse, but I really do appreciate the help.
    10-22-2011 09:55 AM
  5. tonysracing's Avatar
    No problem......you'll need to unzip the driver .rar file and double click it to install the drivers. you can also use winzip or winrar to extract the files.
    10-22-2011 12:10 PM
  6. jstkiddn's Avatar
    Thanks. Finally got it going. I think I did it all correctly (after the phone rebooted I'm being prompted to activate phone, which is exactly what I should see....right?) but sadly the touch screen still isn't working. The only thing that has me confused is that RSD Lite has never said 'complete'. It says "please manually reboot phone" and progress says "100%"....but it still says "in process". under result. And if I try to close the program it gives me a warning that it's busy and I could damage the device if I close it. Does that mean I did something wrong?

    It's quite possible that I didn't hear the entire story on the original rooting endeavor so there could be something else going on that I'm not aware of.

    Unless anyone has any other ideas, maybe it will make a lovely coaster.
    10-22-2011 01:52 PM
  7. tonysracing's Avatar
    Yes...you didn't let RSD finish. When it says manually reboot phone, You need to to a battery pull and restart the phone using the power and volume up switch, and back to RSD Mode. RSD will eventually say PASS instead of IN PROGRESS.
    10-22-2011 03:40 PM
  8. jstkiddn's Avatar
    Yes...you didn't let RSD finish. When it says manually reboot phone, You need to to a battery pull and restart the phone using the power and volume up switch, and back to RSD Mode. RSD will eventually say PASS instead of IN PROGRESS.
    Oh! DUH! Thanks!

    Okay...did it all again (this time letting it get to "pass", disconnected, rebooted and touch screen is still a no go.

    Have I done all I can do?

    Again...THANK YOU for your time.
    10-22-2011 05:44 PM
  9. tonysracing's Avatar
    If you've successfully flashed the SBF file like you've said, then there must be some type of hardware issue going on with the phone.
    jstkiddn likes this.
    10-22-2011 10:06 PM