1. tlk's Avatar
    When on WiFi the phone will disconnect briefly and then reconnect to the WiFi signal. This has happened with two different wireless routers. Works fine on 3G, problem only occurs on WiFi. Started noticing the problem after the latest update. Anyone else having this issue? Any thoughts?

    Thanks
    05-27-2012 10:13 AM
  2. srvctec's Avatar
    Have you rebooted? Have you tried a battery pull with the power on?
    05-28-2012 11:16 PM
  3. Devinator's Avatar
    Does this occur while you are actively using it? Or is it after your screen times out?
    05-29-2012 08:55 AM
  4. Quezop's Avatar
    Me and sister phones are currently having the same exact problem. We've tried pulling our batteries and leaving them out for a few ... this is very frustrating it makes me really not even want this phone anymore D: also for us it occurs when we are actively using the phone.
    05-29-2012 08:42 PM
  5. tlk's Avatar
    Yes I have tried a reboot and removing the battery. And yes it occurs as I am using it. Very frustrating but at least I'm not the only one :/
    The WiFi icon will turn from blue (active) to white and then disappear, changing over to 3G and then reappear a few seconds later.
    05-29-2012 11:09 PM
  6. Devinator's Avatar
    Have you tried a factory reset? If so and it didn't work, I'd suggest contacting your carrier for a replacement.
    05-30-2012 09:21 AM
  7. wyattspoppa's Avatar
    In case you hadn't resolved this, it is well known that the last update was a problem. When I contacted Verizon, they immediately told me they were sending me a new phone as the update is what crashed my phone and they had no "patch", that it must be replaced. It was weird, they must have known it went terribly wrong as the rep never asked me a single question.
    06-08-2012 01:06 PM
  8. Devinator's Avatar
    Really? An update made it so that you can't factory reset your phone back to working status? That seems odd.
    06-08-2012 01:41 PM
  9. hck0's Avatar
    I am having the same problem too! The irony is that my "push" capability was compromised and I didn't get the latest software upgrade until I Factory Reset the phone! I have talked with Motorola Level 3 support and Verizon Level 2 support and no-one wants to take the blame for this or there seems to be a vague knowingness about the problem!

    I have tried many, many things to resolve this problem: 3 factory resets!; loading no apps before logging into WiFi; deleting/recreating remembered networks; changing the channel on the WiFi; etc. etc. with no luck. Motorola has "no plans" to upgrade this software and it's impossible to backtrack to the earlier one which actually worked just fine!

    It's outrageous that we are totally at the mercy of these behemoths who charge a lot for their services but drop you like a hot brick when the going gets tough
    06-13-2012 05:07 PM
  10. Devinator's Avatar
    I'd call Verizon back. They will make it right. It's not working as it should, which means it should get replaced VIA warranty (unless you got your phone right when the X2 launched and your manufacturer warranty is up and you don't have the extended warranty). Call back as many times as you have to. If you get no where with whoever you are talking to, hang up and call back.

    Worst case, have you tried a custom ROM?
    06-13-2012 06:24 PM
  11. tlk's Avatar
    I will be contacting big V to get a new phone. Thanks to you all for your help and feedback. Good luck to you other guys with this problem. I'll post my results.
    06-13-2012 11:02 PM
  12. Devinator's Avatar
    Good luck!! I look forward to hearing of your success. Don't forget to hit the thanks button if someone helped you.
    06-13-2012 11:22 PM
LINK TO POST COPIED TO CLIPBOARD