1. jared20smith's Avatar
    So, I reset my x2 back to GB 2.3.4 and used Pete's Motorola Root Tools. This in turn created problem 1:

    I have no signal. I've tried everything i can think of, from clearing the cache, factory reset, etc, no dice.

    However, I figured I'd press on because CM9 looks so dang nice. I downloaded Rom Manager and downloaded the CM9 ROM. I dont have an sd card, but i read on multiple sites that the internal sd card is fine. So i tried flashing the Clockwork Mod Recovery and installing CM9, but it wasn't there! So i went into astro, tried to move the files into the root folder, but i couldnt. SU wasnt blocking anything so i figured it might just be the app. I then downloaded es explorer and managed to move the files into the root folder. Still, upon attempting to install, nothing. Bewildered and frustrated, i decided i'd just shell out six bucks for the premium rom manager and DL the ROM there. NOPE! I bought it, fixed permissions, restarted my phone, changed SU permissions, and i cant even see the premium roms available! And now, to top it all off, i cant even get a refund!

    For the love of God somebody help me please!
    07-22-2012 06:05 AM
  2. maggard5's Avatar
    ROM manager doesn't work on the x2. Also, the official version of CM9 will not work on the x2.

    The only way to get CM9 is to use dragonz version found here:


    Sent from my DROID X2 using Android Central Forums
    07-26-2012 11:31 PM
  3. JStiner's Avatar
    You also have to use 2 versions of BSR.
    Read the directions step by step at the above link

    Sent from my GT-P1010 using Tapatalk 2
    07-30-2012 07:48 AM