1. sirmichael's Avatar
    OK, so I thought I'd start a thread for all issues related to Exchange.

    1. Had some trouble getting it to sync. Finally got it to work after about 30 minutes of trying. No explanation.

    2. Doesn't sync with Exchnage when I'm on WiFi.

    3. Exchange email app doesn't let me accept or decline a calendar invite. Or at least I haven't found out how yet.
    11-06-2009 04:18 PM
  2. sirmichael's Avatar
    4. Unable to create an email signature for Exchange email.
    11-06-2009 04:19 PM
  3. austink's Avatar
    5. Can't file messages in folders

    6. Can't change alert settings so that new messages show in the notification bar, WITHOUT the LED flashing (in the Facebook app you can have it show in the notification bar with no LED flash, so it is possible)
    11-06-2009 06:14 PM
  4. khakiandcashmere's Avatar
    I am having a really hard time setting my exchange email up. I have tried my OWA address and the direct IP... what did you use for the server setting?
    11-06-2009 07:31 PM
  5. DROIDFREAK's Avatar
    I think the exchange setup is more difficult than it has to be. I think it may be an os issue, but it seems like everyone is having trouble setting this up.
    11-07-2009 12:46 PM
  6. austink's Avatar
    I installed touchdown and it seems to do everything fine. I am amazed at how poor the built in exhcange sync is.
    11-07-2009 02:39 PM
  7. stonehamandroid's Avatar
    I had similar issue setting up exchange on my Hero. After playing around with it for several days and have Touchdown work I discovered I was using the wrong domain name. Not being an IT person I was trying to use the percieved web domain name from the exchange and company web address. For example androidcentral without the .com at the end. What it really was looking for was the company domain my Windows login was associated with. Depending on how your pc is setup you might see it in the login panel on your desktop or you might use it as part of your user id like Corporate\userid. I have seen things like WIN or Corporate used. I found mine in Web Outlook under options and change password. Once i used this as my domain and filled in the exchange server info and password it work with no issues.
    11-07-2009 04:48 PM
  8. ncbryan's Avatar
    I have tried every server setting combination and still have not gotten exchange to work. I have talked to VZW and MOTO tech support for hours and still no solution. I believe it is a setting on our server, but nobody can tell me how to set it up. All I know is there were no special settings required on our exchange server to get the email to work on my Storm. The other weird thing is my calendar syncs perfectly and FAST using my exchange settings on my phone, but I can not get the contacts or email to work at all! I am temporarily using Touchdown to get my email on my Droid, but there is no telling what the delay is going out or coming in. I am on a free 5 day trial on Touchdown, so if VZW or MOTO can't figure out my exchange by then, I am not sure what I will do? Might return the Droid and either go back to my Storm or get a Storm 2? Undecided.
    11-07-2009 05:35 PM
  9. dwlace01's Avatar
    Having gone through this with the iphone and my exchange server I can assure it is not the phone. Your exchange server has to meet several requirements before it will work and it has to be setup correctly. I have configured severl servers to work with the iphone and bc the droid and the iphone both use activesync, I can only assume the setup is the same.

    I would be more than bhappy to help those that have access to their exchange server configure it correctly.
    11-08-2009 09:25 AM
  10. Mitch R.'s Avatar
    Would you post screen shots of the windows under Exchange Manager that contain the right settings?
    11-08-2009 09:47 AM
  11. EverythingiDont's Avatar
    7. Messages in folders do not load - stare at completely blank screen
    8. Can't search accross exchange server contacts that aren't in your local contacts (I.e. On iPhone, when I start typing an email address it will search exchange server to find match).
    11-08-2009 12:03 PM
  12. EverythingiDont's Avatar
    Has anyone figured out the subfolders issue? Emails simply don't display unless they are in the inbox. All I get is a blank screen. This is a huge problem for me - I had to reactvat old phone until this is fixed...
    11-08-2009 06:39 PM
  13. wcallen's Avatar
    Having gone through this with the iphone and my exchange server I can assure it is not the phone. Your exchange server has to meet several requirements before it will work and it has to be setup correctly. I have configured severl servers to work with the iphone and bc the droid and the iphone both use activesync, I can only assume the setup is the same.

    I would be more than bhappy to help those that have access to their exchange server configure it correctly.
    dwlace, can you contact me to help with configuring our exchange server. I am the IT guy for our small office and can not figure out the correct setting for our exchange server. Thanks
    04-12-2010 12:18 PM
  14. wcallen's Avatar
    dwlace, can you contact me to help with configuring our exchange server. I am the IT guy for our small office and can not figure out the correct setting for our exchange server. Thanks
    04-12-2010 12:19 PM
  15. PJnc284's Avatar
    Touchdown is much more robust than the native exchange support. The trial version doesn't allow an email signature but the licensed version one will let you enter one. The native app also doesn't support security policies on the exchange server. Touchdown also gives you the ability to sync certain folders and move messages easily between them.
    04-12-2010 12:26 PM
  16. takeshi's Avatar
    dwlace, can you contact me to help with configuring our exchange server. I am the IT guy for our small office and can not figure out the correct setting for our exchange server.
    This is an old thread. Dwlace's last post was the one in this very thread. I doubt you'll get an answer.

    Are you looking for help configuring the Exchange server or with configuring the Droid's Email app to access the Exchange server?

    I'd also highly recommend Touchdown for anyone that needs access to an Exchange account on Android.
    04-12-2010 01:10 PM
  17. HyTeK's Avatar
    The first question to ask is, does any user that has Windows Mobile able to connect without issues? If no, then Exchanges ActiveSync is setup correctly. If not, then your Exchange server is not ready for mobile connections yet...

    If exchange is working with a Windows Mobile device (or has worked before):

    1. Under ADUC, open EACH user that needs access to email via their mobiles. Under the Exchange Features tab, ENABLE all Mobile Services. (Outlook Mobile Access, User Initiated Sync, and Up-To-Date Notifications)
    2. Under ESM, go to Global Settings, right click on Mobile Services, and go to properties. Just for a test, put a check mark in every box on the General tab. Go to Device Security now, and uncheck Enforce password on device. (these settings are not secure, but at least we will be able to test if exchange is truly setup for mobile access)
    3. Under ESM, go to Recipients, under "Offline Address Lists", right click on "Default Offline Address List" (you may have other ones, but you should at least have the Default one here), click on "Rebuild". Depending on the size of your Active Directory, you may have to wait 5 minutes, 10 minutes, or even and hour. (usually 5-10 is average for a small-medium size business). This will force a rebuild of all the AD information into exchange, which speeds up the changes we made in ADUC earlier.

    Now, after you have waited 5-10 minutes (or longer), try refreshing your droid again. As long as exchange's activesync is setup correctly, you should be able to start receiving emails. If not, check your log's on the exchange server. (check IIS logs for connections to see if your user's mobile is indeed trying to contact the server, check security logs to see if the password/user/domain is correct, check exchange logs for errors in settings or access attempts)

    If none of this works, then my advice is to go through and check/reconfigure your exchange for mobile access (activesync). Most of this will be done through the IIS manager. (most likely wrong settings somewhere)

    And lastly, the biggest problem I have seen are SSL certs that are self signed, or not configured correctly. I highly recommend checking your SSL certificate for accuracy. (or if self-signed, have your intermediate certs installed onto the droid device)

    Cheers
    08-05-2010 08:32 AM
  18. HyTeK's Avatar
    oh, and the reason I revived the dead thread, this page was ranked high on google for exchange/droid-x problems. So figure post something useful, then reading nothing that helps at all.

    Cheers.
    08-05-2010 08:33 AM
  19. jordo's Avatar
    Yes like dwlace01 said, your Exchange server has to be configured to allow this type of connection. Most are either setup to accept Activesync connections or POP3/IMAP. If your having trouble with it, I suggest contacting your IT people and ask for some help (and as a fellow IT guy, be nice )
    08-05-2010 08:39 AM
  20. raking08@gmail.com's Avatar
    Seems I am in good company. Everything with th enew charge is so far great except getign the exchange to connect. I know our servers work fin for iPhones and also for my old BB8830. Are there different server settings for the DROID ?
    Silly question, on a droid do i need to use the VPN to log onto the exchange server???
    05-20-2011 02:28 PM
LINK TO POST COPIED TO CLIPBOARD