1. Storm_75's Avatar
    Has anyone had any issues getting their Comcast e-mail account to work properly with their Moto Droid? I tried setting mine to match up with my Windows computer e-mail app, settings below. It accepts the settings and seems to "approve" them, but the actual use is just flaky. Now it doesn't work at all?

    My separate G-Mail account works great, as I expect it would on Android!

    Here is what I am using on for Comcast on the Droid:

    Incoming: mail.comcast. net Port: 110

    Outgoing: smtp.comcast.net Port: 587

    No SSL on either...

    Also matched up everything with the suggested settings on the Comcast Web site and all looks good... anybody?


    06-04-2010 03:29 PM
  2. specops2k3's Avatar
    mine works fine, but i always get duplicate emails
    06-04-2010 03:38 PM
  3. CharlieL3's Avatar
    I just put in my account name and let the Droid make all the settings automatically. It works very well, except that only the inbox is synched. The settings that the Droid picks don't match the ones you have above. Try deleting the account, and then setting it up again, but let the Droid make the settings. I think you'll be pleased with the results.
    06-04-2010 07:02 PM
  4. anthonyzul's Avatar
    I set my Comcast email up to forward to my Gmail account. Then I set it up to be able to send Comcast email through my Gmail. So I only use the Gmail app on my phone. Works perfectly! Admittedly though, the Gmail app does not have the ability to send as Comcast like you can on the desktop. I never need to send mail from Comcast email anyway so it isn't a problem for me.

    Maybe if you can't get it to work you can set it all up this way and use the Gmail mobile site to send out your Comcast mail.
    06-05-2010 10:06 AM
  5. bizymare's Avatar
    Try this checklist from Motorola. It fixed mine. https://motorola-global-portal.custh...can't-send)
    09-25-2011 10:15 PM
  6. beach4100's Avatar
    If you are using Outlook go to its Tools>Account Settings>Change existing e-mail accounts>next
    Select Change>select More Settings>select Advanced Tab>check "leave a copy of messages on server">select OK>select Next>select Finish.

    Now set up your Droid X2 Comcast e-mail Account as follows: Incoming Server=POP>server = mail.comcast.net>fill in your Comcast e-mail address and PW>touch Advanced
    port = 995>check "use secure connection">use secure PW = Auto>Authentication = PW>verify certificate= unchecked.
    Outgoing server=smtp.comcast.net>User name=your Comcast e-mail address>fill in PW>
    touch Advanced>Port = 587>use secure connection=unchecked>use secure PW=Auto>Authentication = Auto>verify certificate = unchecked

    After a failed 4 hour Verizon Tech Support marathon
    and another about 6 hours myself this worked----just tripped on it----good luck.
    12-05-2011 11:44 PM