1. duke3913's Avatar
    So I began to root awhile back and installed the spr recovery. I never went further than that. I then tried to apply the new 2.2 update as mentioned and quickly discovered that technically I was rooted so this would not work. So I unrooted back to stock 2.1. I now have again tried to install 2.2 and it continues to fail. failed to verify whole file signature, and signature verification failed. installation then aborts. I have downloaded the 2.2 update several times to ensure it has downloaded correctly and every time I come back to this. Any ideas?
    08-03-2010 09:04 PM
  2. thebizz's Avatar
    Do you still have the spr recovery or did you use the sbf and fully unroot and if worse comes to worse root and install Pete's fro01b or whatever the build number is same thing just leaked ahead of time with root
    08-03-2010 09:12 PM
  3. duke3913's Avatar
    no i did a complete unroot. thanks for the reply this is really frustrating been battling it for 2 hours now
    08-03-2010 09:19 PM
  4. JJRocker's Avatar
    I had the same problem and I've never rooted my droid. I downloaded about 5 times and got the signature error. I noticed that the size of the download was only 17MB(should be 45MB). Then I tried the link that downloads from MegaUpload and everything worked fine. I would keep trying to download it until it downloads the full file size. Most of the links are probably getting hammered until the OTA rolls out.
    08-03-2010 10:02 PM
  5. duke3913's Avatar
    yeah the file size i have is correct. i have since tried to re-install spr recovery and can't even do that. rsd lite wont acknowledge the sprrecovery.sbf file? wth is happening here.
    08-03-2010 10:05 PM
  6. duke3913's Avatar
    droid x it may be tomorrow.
    08-03-2010 10:06 PM
  7. WAM's Avatar
    make sure the update is not named update.zip.zip (you can check using astro as your computer can lie to you/long press/rename), or even worse update.blankidyblank, but just update.zip hope i helped. also make sure the update isn't inside in any folder but is just sitting on your SD card
    08-03-2010 10:06 PM
  8. duke3913's Avatar
    yeah it's not. trust me i've looked on every site and tried just about everything. i'm seriously about to have a motorola droid insurance claim as this thing may not make it through the night
    08-03-2010 10:16 PM
  9. duke3913's Avatar
    the only thing that strikes me as odd is i dont' believe my current 2.1 is a verizon build. it does not say es81 or whatever under the build. it says voles-userdebug 2.1 update 1 ese53 25914 test-keys? the file i downloaded said official. so i wonder if this build is locked in for some reason or another because i can't get anything to work
    08-03-2010 10:20 PM
  10. corydunbar's Avatar
    if you still have a custom bootloader i would just flash a completely different ROM that is stable, then use ROM manager (in the market) to do whatever you need it to.
    08-04-2010 08:12 AM
  11. duke3913's Avatar
    Currently its stuck on a 2.1 build without root. RSD lite won't allow me to flash anything. This phone is on borrowed time. It may just get wrinkled.lol
    08-04-2010 08:47 AM
  12. corydunbar's Avatar
    can you boot into recovery? you don't need a PC to do this.
    08-04-2010 09:00 AM
  13. duke3913's Avatar
    yes i can
    08-04-2010 09:09 AM
  14. corydunbar's Avatar
    what recovery does it say at the top? If it is Clockwork or SPRecovery you can just do a nandroid restore.
    08-04-2010 09:20 AM
  15. corydunbar's Avatar
    If you're looking for help follow it here: http://forum.androidcentral.com/moto...wth-droid.html
    08-04-2010 09:23 AM