1. Sooks's Avatar
    Ok so i have followed this guide to the letter :

    [How-To] Back to Stock, no su, no BusyBox, etc. - Page 2 - Droid Forum - Verizon Droid & the Motorola Droid Forum

    i no longer have root , but i still have my superuser icon , and i need it gone , my mic in the phone has stopped working and i need to take it back to verizon in the morning before school , any help would be freaking awesome ! thanks -sooks-
    01-06-2010 02:04 AM
  2. Sooks's Avatar
    25 views...... and no one ... ugh help me ppl lol, this is the one thing i miss about blackberry ( and crackberry)
    01-06-2010 02:57 AM
  3. Sooks's Avatar
    Ok another question , if i were to go and wipe all data/ and wipe the partition or whatever , the load the 2.0.1 update from the normal recovery mode ...... would that wipe my phone clean now that i dont have root ? and it will be all good and get rid of that super user icon ?
    01-06-2010 03:20 AM
  4. Tennessee's Avatar
    Not sure Sooks, I have not rooted mine as yet just helping by getting this back to the top of the list for ya.
    01-06-2010 08:41 AM
  5. Roy Aguilera's Avatar
    Apply the zip update and restore to factory. That did it for me.
    01-06-2010 09:07 AM
  6. Roy Aguilera's Avatar
    25 views...... and no one ... ugh help me ppl lol, this is the one thing i miss about blackberry ( and crackberry)
    Not many members here have rooted and the few that have, have not unroot.
    01-06-2010 09:09 AM
  7. vsugorilla9's Avatar
    this was in a post somewhere around this forum and it worked perfect for me

    "1. Re-root your phone (yes make sure your phone is "jailbroke" again) and download an app in the market called Terminal Emulator (its free)

    2. Now type the following in the terminal emulator app. One line at a time and pressing enter after each line

    su
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system
    cd /system/app
    rm Superuser.apk
    mount -o ro,remount -t yaffs2 /dev/block/mtdblock3 /system



    3. Sync phone with google (in the settings)

    4. Reboot phone

    5. App should now be gone...

    6. Reapply unrooted OS and wipe device .

    7. Should be unrooted and the app will be gone..you can check your root status by using the Terminal Emulator app and typing "su" it should say permission denied"


    this did it for me. i had my headphone jack mess up and they sent me a replacement so i needed to unroot it as well. this did it for me. only thing is you will have to reroot it and then download android terminal manager then enter those lines into it and then restart and that will remove superuser icon and permissions and then you will have to apply the original update.zip and then it is unrooted without the superuser icon. worked good for me but you do have to follow the directions very closely. its not hard but you must do it exactly right.
    01-06-2010 09:26 AM
  8. dagostin's Avatar
    You must have root to remove superuser.apk as it's in a non-writeable partition that only root can access. So follow instructions from earlier post about how to remoeve. Then you can run the oem update again which will remove your access to using su.

    Please note that you really run extremely little risk bringing in a phone to verizon that has superuser application on it. 99% of verizon staff will have no clue what it is and 99.5% will know nothing about where applications are installed or how to detect anything. You are fine, just bring it in.

    One last note, the instructions on how to "unroot" from that forum will NOT work at all and possibly hose your phone if you were running a 2.1 rom. the 2.0.1 OEM update.zip was an incremental patch that expected your phone te be in the 2.0 or 2.0.1 state. If you had loaded a 2.1 modified image, running the the update.zip is not recommended at all, you should first restore to your 2.0.1 build.
    01-06-2010 09:40 AM
  9. vsugorilla9's Avatar
    yes thank you i forgot to mention that. you must load the 2.0.1 first. if you have to 2.1 rom loaded you will need to load back up the 2.0.1 that you probably backed up with nandroid. other than that you are golden and shouldnt take too terribly long to do.
    01-06-2010 09:51 AM
  10. Sooks's Avatar
    Ok thanks for the help ,my mic started working again lol , so idk , i plan on re-rooting and tinkering again lol
    01-06-2010 02:06 PM
  11. Lotus17ss's Avatar
    ok all I see is the update.zip on my sd card . where do you find the 2.01 file ?
    01-06-2010 07:34 PM
  12. dagostin's Avatar
    Not sure what you're asking here or what state your phone is currently in. More info.
    01-06-2010 08:42 PM
LINK TO POST COPIED TO CLIPBOARD