1. queueman's Avatar
    This is a very bizarre issue, I think. I've had two instances where I could not type some characters in a specific place.
    1. I was entering a phone number with the format (where #is actually a numeral): ###-###-####. It was going fine until I tried to type the second dash (-). I could not type that character. I tried both virtual keyboards and the physical keyboard. Nothing! I tried typing a number in that field, and it was OK. It would also take a period (.), but refused the dash.
    2. Second instance was worse, because I must type the @ character when entering an e-mail address. I was trying to log in to a site, where the login is my e-mail address. I typed name, then tried to type @, would not work on any of the three keyboards. I could type a letter in that area, but not a @.
    WTF?
    I've only had the Droid for about three days. In general I like it, a few drawbacks, but this one would be a deal breaker, and I'd have to return it.
    Any suggestions on a fix?

    OK, I figured out that the phone number thing is pilot error. When entering a phone number, don't type the dashes, the Droid will fill them in automatically. Maybe the problem with the @ symbol is from AT&T? I was trying to log on to U-Verse.
    03-28-2010 02:30 PM
LINK TO POST COPIED TO CLIPBOARD