1. cktp4400's Avatar
    I got the triumph and am having a problem with charging the battery.. When the phone is off, it seems there is no problem charging the phone. When the phone is on, the charger is connected to the phone, the battery indicator on the upper right does not change (usually this change showing the plug picture when connected to the charger), and when I check in the setting -> status, it says "not charging". Does anyone have the same issue? Anyway to fix? Thanks in advance.
    07-17-2011 09:25 PM
  2. Etegral's Avatar
    Are you using the USB cable provided with the Triumph? I tried using the USB cable I used for my Optimus V and it doesn't work, but the cable included does.
    07-18-2011 04:26 AM
  3. lance1955's Avatar
    From what your saying there it sounds like a problem with the phone internal charging circuit. IE a defective phone.
    07-19-2011 12:49 PM
  4. raybird's Avatar
    So far mine will charge using my wall adapter at home, but not my car adapter (with phone off yes, with phone on no). The USB cables are different so I don't know if it's the cable or the adapter. My Optimus V works fine with both.

    I haven't tried the included cable in the car yet, but if the cable makes a difference doesn't that take the "U" (universal) out of USB??
    07-20-2011 08:18 AM
  5. phreekx's Avatar
    I have the exact same problem. charges when turned off but not when turned on
    07-20-2011 11:23 PM
  6. rockneo's Avatar
    Universal means its used around the globe, when they reviewed the phone they said you have to use the cables it came with

    Sent from my Optimus V
    07-21-2011 09:23 AM
  7. anon(24109)'s Avatar
    I haven't even open my official charger yet. I plugged it into a BlackBerry cable on a generic USB car charger, a Nook cable on my laptop and my old Optimus V charger on an outlet. All of them worked fine and the phone was on the entire time.
    07-21-2011 09:56 AM
  8. StreetPirate's Avatar
    I just bought one on the cheap. It's the USB cord. My generic one didn't work, no USB tho. The 1 I had in the car USB charger did. Go figure.

    But it's charging.

    Yeah.
    08-29-2012 11:48 PM
LINK TO POST COPIED TO CLIPBOARD