1. Doggydude's Avatar
    I was muddling through a crapload of forums talking about MT tethering, and I found a fix.

    You need root, and barnacle, installed on your phone, but the fix is entirely clientside, which sucks. A Lot.

    Apparently you need to change the mtu size. the reason only google pages worked was because googles mtu is smaller than 1472, while the others are the standard 1500 (please correct me if im wrong, i am by no means an expert and this is what I understand from the HoFo forum) The MT only supports 1472, but it does not alert the computer to that on first connect, leading to an error (hint to future kernel devs, apparently this is something you can fix quite easily. dont ask me about it though, go look at the thread. the fix is farther along, around page 10 or so, and people talk about what needs to be included in a kernel)

    here is the fix: (credit to the person from HoFo, I just copied)

    Windows 7:

    1. Click Start, and in the empty field type CMD. To run this command you must run the command prompt as administrator. To do this, after typing CMD press and hold CTRL + SHIFT and then press enter. You will be asked to continue for permission.
    2. In the command prompt, copy and paste (you must right-click to paste in this prompt):

    netsh interface ipv4 set subinterface "Wireless Network Connection" mtu=1472 store=persistent

    Then press enter.
    3. If successful, you will see Ok.
    4. Then, start up barnacle and connect again and try another page other than Google.

    Thread: Motorola Triumph Wifi Hotspot Tethering

    First fix, very confusing: Motorola Triumph Wifi Hotspot Tethering - Page 7

    More instructions i pulled from the forum:

    Ipad instructions (seems pretty sketchy to me, but i dont even have an Ipad):

    if you have openssh installed and network-cmd packages.

    ifconfig en0 mtu XXXX

    The XXXX is the MTU number.
    (you should change the mtu to 1472 if i know what im talking about)

    Mac Instructions:
    Phone Side
    1) Root using Gingerbreak 1.2
    2) Install Barnacle Wifi Tether

    Macbook Side
    1)Go Apple icon/System Preferences/Network/
    2) Once in Network click the plus symbol (bottom left) to add a new "wifi" interface.

    The reason why you create a new wifi profile all together is to make it so that when you connect to your normal home wifi setting (WHICH YOU SHOULD HAVE...no bandwidth hogs ) everything stays normal and in order. Now when you log back into your home connection just change the network preference to the normal "wifi" connection.

    3) Name it Virgin Tether or something other than wifi
    4) Click Advanced then click the far right tab for "Hardware"
    5) Where it says MTU select "Custom" and then in the box type 1472

    Go back to the phone
    1) Open up Barnacle and click start. You will see in red "NAT: Could not set MTU of rmnet0: Invalid argument."

    Now this is the hardest step in the WHOLE process....

    IGNORE. THE. ERROR. (ha.ha.ha.)

    Go back to your mac
    2)With Barnacle running, click the airport wifi icon on your mac. You will either see "barnacle" as a selectable network under "devices" or you will have to click on Open Network Preferences Select Virgin Tether (or whatever you labeled it as) from the list and then under the network name find barnacle or click join other networks and then select barnacle.

    Once you are connected you should be good to go.

    Kernel Devs:


    this is the guys whole post, I dont understand any of it, but hopefully it helps you
    OK a little more investigation:

    There is an option in wifi tether that allows you to turn on mss clamping, which will in theory tell iptables (the kernel module in the phone that does the tethered routing and NAT) to start all network conversations with a maximum MTU size.

    Here's the command in /data/data/com.googlecode.android.wifi.tether/conf/tether.edify to turn this clamping ON.
    /data/data/com.googlecode.android.wifi.tether/bin/iptables -t mangle -I FORWARD -s " + getdfg("ip.network") + "/24 -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu

    If you try the setting manually at a shell prompt you get:
    iptables v1.3.7: can't initialize iptables table 'mangle': Table does not exist (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.

    OK more research indicates that the kernel must support the
    CONFIG_NETFILTER_XT_TARGET_TCPMSS and CONFIG_IP_NF_MANGLE for this command to work. The TCPMSS extension is only valid in the "mangle" table.

    Looking in /proc/config.gz we see that neither of these is supported. This is also why the mss clamping option does not exist in the wifi-tether user interface (it checks for the features before showing their config).

    To make a long story short, we need a loadable kernel module or a custom kernel to enable this automatic MTU clamping functionality via the mangle table.

    That said, you can still set your max MTU on your tethered devices. In fact, I think ppan76 is right:
    I didn't have to do any changes to the MT. I just changed the MTU size on the client (my iPad) to 1472 and everything worked.
    I don't think setting the MTU on the triumph is necessary at all, the MT will obey the MTU your client sends. I just checked my Triumph and the MTU's are set as rmnet0=1472 and wlan0=1500. Then I set my laptop MTU to 1472 and tried several non-google sites. They all worked fine. Can anyone else confirm this? That sure would make things simpler.

    Setting a lower MTU doesn't hurt much, it lowers the maximum data payload of a TCP packet, so it will create more overhead and thus slow things down a bit for your other non-Triumph connections if you don't set it back to 1500. You can be the judge on whether a 28 byte smaller packet important to you or not

    There is also a batch file that someone made from that forum that will do it for you. il attach it, and also an untested one that I made. Took the origination one, and changed the MTU to 1500, so you would run it once your done to change it back to normal. there is Linux and Mac instructions on the forum as well

    and lastly:
    I am a complete newb, and I have wanted to help people with stuff like this for a while, so all criticism is appreciated, but try to keep it polite. I really dont know what im doing, and this is my first step into stuff like this, so all support and help would be greatly appreciated
    tonymontana2367 likes this.
    08-03-2011 04:04 PM
  2. Doggydude's Avatar
    heres the batch files: MTUchanger1 is to get tethering working, MTUchanger2 is to put everything back to normal. Testers would be appreciated for the second one, I put it together on the fly and i havent even used it yet
    08-03-2011 04:06 PM
  3. austrie's Avatar
    What about for ubuntu

    Sent from my MOTWX435KT using Tapatalk
    08-20-2011 06:49 AM
  4. idbl_fanatic's Avatar
    heres the batch files: MTUchanger1 is to get tethering working, MTUchanger2 is to put everything back to normal. Testers would be appreciated for the second one, I put it together on the fly and i havent even used it yet
    It works.
    08-20-2011 07:06 PM
  5. Doggydude's Avatar
    What about for ubuntu

    Sent from my MOTWX435KT using Tapatalk
    ifconfig wlan0 mtu 1000
    edit: actually use: ifconfig wlan0 mtu 1472
    The person on the thread used that. I don't have a linux box right now to test it on, but I think you should actually change the 1000 to 1472. Run it through terminal of course, comment back if it works and I'll add it to the instructions
    08-20-2011 08:01 PM
  6. Doggydude's Avatar
    It works.
    Thank you very much
    08-20-2011 08:02 PM
  7. coactusvi's Avatar
    For a better solution, see my post here:

    kaffeine.cf/2016/02/05/forcing-mtu-for-clients-of-androidap/

    You will need a rooted device, btw.

    Vi
    02-05-2016 01:40 PM
LINK TO POST COPIED TO CLIPBOARD