1. jldeitch's Avatar
    My Droid X (Liberty .9) tried to update to the latest Gmail (2.3.5) this morning. I got the improperly signed packet error. So I renamed the Gmail.apk to Gmail.apk.old, rebooted and downloaded a fresh copy of Gmail. However, it FC'd immediately, and refused to run. Cache cleanings, etc., did nothing to fix the situation.

    I returned to the older version, so at least I'm getting my Gmail. But I'd like to get the newer version running if I can. Any thoughts/suggestions on what's going on and how to fix it?

    07-29-2011 11:38 AM
  2. jsharp's Avatar
    I am getting the same error message. Anyone figure this out yet. (Also running v.9 liberty)
    07-29-2011 02:00 PM
  3. Lazlo Hollyfeld#AC's Avatar
    I used TB to uninstall Gmail, rebooted, then installed the new one from the market.
    jldeitch likes this.
    07-29-2011 05:42 PM
  4. ultravisitor's Avatar
    Wow. People are still using Liberty?
    07-30-2011 01:52 AM
  5. jsharp's Avatar
    It took some fighting but using Lazlos advice I got it to work. I think Gmail could still use better contrast between read and unread email. I think the blur email is better.
    07-30-2011 08:59 AM
  6. jldeitch's Avatar
    Worked for me, too, but also after a minor little bit of wrestling. TB is the key -- it uninstalls more cleanly than the other options I had at my disposal.

    W/r/to Liberty, it's stable and it's worked a ton better than the rooted stock I used to be on. There may be other options (e.g., CM7), but I just don't have the time right now to SBF back and set things up again.

    May play with Justice during a couple of long car drives we've got coming up. Or straight CM7. But, for now, I need a fully functioning phone much more than I need to fiddle with ROMs <sigh>.

    Thanks, y'all...
    07-31-2011 01:33 PM
  7. xelhabb's Avatar
    I was just about to post for this and saw the fix. TB uninstalled and the new Gmail loaded and installed without error. Just make sure to go to your accounts and manually re-sync after the install.

    Of course people are still using Liberty. However the Dev doesn't seem to be supporting the ROM is enthusiastically as before. Maybe work has him busy. I am using vo.8 because 9 totally went batty on me with the keyboard force closing. I'll be with Liberty until the Bionic comes out.
    08-10-2011 02:32 PM