1. vor's Avatar
    Updated SU last night and it restarted saying SU binary is outdated but I cannot update it, keeps crashing.
    09-27-2011 02:22 PM
  2. vor's Avatar
    seems to be a known issue with various fixes depending on your device, chainsDD as updated his blog:

    09-27-2011 04:03 PM
  3. vor's Avatar
    Very weird experience with this. I thought I had lost root, and in fact I had whenever I tried to run anything on my phone. But whenever I shut down the phone and repowered on I could get into recovery. I did this 3 times. Finally the last time I had downloaded the zip file and was able to install via recovery, I thought I was going to have to wait until I got home to use a computer to restore root. Anywho here's the zip file location in case anyone needs it for the recovery install of SU 3.0

    09-27-2011 05:20 PM
  4. ggoomani's Avatar
    I have found some info that, in my case, says the issue is my rom. I've enjoyed srf 1.2 (sprint epic) for months now, but this is the 1st sign that makes me want to look into a fresh rom install of something more updated.

    read here:
    "2) Binary updater fails to update binary – This usually happens because for Superuser can’t write to the system partition where the binary is installed. This can happen for a couple reasons. First, and most common, is that your device has S-ON which prevents the system partition from being written to at runtime. Even if a remount succeeds, and the system thinks that the partition is mounted as rw, you can’t write to it. There are different solutions for different devices, but the easiest usually involves simply updating Superuser through ROM Manager. If you were able to flash a custom ROM, you’ll be able to update Superuser through ROM Manager. The other reason that updating the binary fails is that your ROM Dev did something silly like putting the su binary in /sbin. I have not found a reason why this would be done, but I’ve seen it many times. The problem with putting su in /sbin is that even though you may be able to modify it at runtime, the changes will not stick over a reboot. This is because /sbin is part of boot.img, which gets unpacked and loaded at boot. The other problem with having the su binary there is that it’s almost always the first entry in the PATH. If you’re unfamiliar with the PATH, it’s a list of places that the system will look for a program, once it finds one it stops looking. Superuser will not try to update su if it’s found to be in /sbin because the change will not persist. The fix for this is not quite so easy as before and you’ll likely have to change ROM, and let the developer of whatever you were using know that they’re doing it wrong."

    from: Initial impressions of 3.0 written by the author of superuser (claims)
    10-05-2011 04:09 PM
  5. SuperChargedJ's Avatar
    Use Rom Manager to fix permissions and that will resolve the Binary outdated error. I had the same issue and that's how I resolved it.

    Sent from my DROIDX using Tapatalk
    10-05-2011 06:11 PM
  6. jerseyboy357's Avatar
    Im running MIUI 1930. I have the Superuser app that comes w it, and most of my permissable apps are in that one. I also have Superuser from the market with 5 apps in it. Not all the same ones in the MIUI app.
    The android version I have ver. 3.0(35) and binary v3.0 Seems ike I have some cleaning up to do, although there havent been any issues with compatibility yet.
    10-05-2011 06:25 PM
  7. bor999's Avatar
    Use Rom Manager to fix permissions and that will resolve the Binary outdated error. I had the same issue and that's how I resolved it.

    Sent from my DROIDX using Tapatalk
    I tried this and I got this message:

    "an error occurred while attempting to run privileged commands!"
    11-30-2011 11:26 PM