1. drewsome's Avatar
    Hello, this is my first time posting. I looked hard but failed to find the cure. I updated to 2.2 on the x but failed to move su to xbin. So, I flashed back to original with sbf and rooted with the windows gui again.

    I tested barnacle wifi just before I updated again and was getting download speeds of around 9.5 mBs. However, after updating to 2.2 again, barnacle couldn't even put out 1 single kB per sec.

    That, couple with the fact that I was seeing some minor bugs with other things (dialer was weird, physical button weren't backlighting, etc.) I flashed back to 2.1. However, after rooting barnacle wifi is still only outputting less than a kB per sec. Moreover, pdanet's broadband drivers aren't cooperating. Any suggestions? Thanks to everyone in advance.
    08-21-2010 03:42 PM
  2. DThomp's Avatar
    Same here with pdanet. My X doesn't work on the computer and the computer doesn't even recognize the phone, and the phone wont charge from the usb.
    08-21-2010 08:16 PM
  3. drewsome's Avatar
    Hmmm, I did notice my laptop wasn't charging my phone while in "pc mode" with the update yet would charge when I changed it to "usb mass storage". I can't confirm it, but I think it kept charging when I switched back to "pc mode", thus fixing the problem.

    Also, after flashing back to 2.1, my pdanet's drivers on my computer weren't communicating with the app on the phone, so I uninstalled pda on my computer and re-installed it. The installation wizard prompted my to connect my phone so it could pass the necessary drivers through. I worked then. Given, I was in 2.1, yet it might work in 2.2. Good luck.

    Update on the slow wifi tether: the app "Wireless Tether" gives me 3 MBs. Cant' complain but I still do. Barnacle's a no go. Might just update for the 3rd time just to see if I can problem solve pdanet.
    DThomp likes this.
    08-21-2010 08:32 PM
  4. DThomp's Avatar
    That would be cool to have some help. I did manage to get the phone to charge on all the settings but pdanet still wont get me to the internet, although I can get Gmail but that's all I can do on the net. Going to try uninstalling and reinstalling now.
    08-22-2010 06:14 AM
  5. DThomp's Avatar
    Thank You drewsome. I uninstalled pdanet and reinstalled it and it did reinstall the drivers to the phone. WOOT
    08-22-2010 06:32 AM
  6. drewsome's Avatar
    Glad it worked for you!
    08-22-2010 02:16 PM
LINK TO POST COPIED TO CLIPBOARD