1. tanasaprano's Avatar
    Forgive the lack of insight, I am not too familiar with this.

    I am trying to root an old Droid X(2.3.4/.621) with a faulty sd card reader using framaroot. I also don't have access to a PC, though I have access to a Mac Book but not sure if it can write optical media.

    I tried to download the APK, after allowing third party application sources, but then I was instantly reminded of then phone's glaring design flaw. Obviously, the saving to SD card route is not an option and the stupid phone won't allow me to save to internal storage. Way to think it through, Motorola.

    What are my options here, if any? Is there a way to install the exploit without the need to save to sd card?

    If not, what would be the next best approach to rooting it given the resources I have at my disposal? Am I out of luck?

    Any help, tips, advice, etc. would be greatly appreciated. Again sorry for my level of ignorance in the area and thank you very much.

    12-05-2013 02:38 PM
  2. Golfdriver97's Avatar
    Have you tried TheUnlockr? They have some decent methods to root devices.
    12-05-2013 10:37 PM
  3. tanasaprano's Avatar
    Yes, but nothing really addressed a situation where the memory card reader within the phone is not working. There may be one method listed on there that I could attempt when I get back to my PC, though it certainly doesn't approach the simplicity that many other methods offer.

    I may not even bother, as I use a Note 3 and have no need to ever turn the Droid X on again. But I would have liked to use the experience as a litmus test to guage wwhether it was worth considering root on the Note 3. I'm not going to entertain the idea of voiding a $700 warranty without knowing if the risk is worth tthe gains in performance, functionality, battery, etc.
    12-06-2013 12:16 PM
  4. Vinaychandel1230011's Avatar
    Framaroot application is a one-click rooting app, which lets you to root your Android smartphones and tablets just by clicking the any of the exploits given in the app. download framaroot
    02-16-2016 01:22 AM

Similar Threads

  1. No LTE after Battery Swap
    By BryanEW710 in forum Droid Bionic
    Replies: 4
    Last Post: 12-10-2013, 10:25 AM
  2. Galaxy s4 4.4, no signal, return to 4.3 or 4.2
    By steve song in forum Samsung Galaxy S4 Google Edition
    Replies: 2
    Last Post: 12-09-2013, 10:16 AM
  3. VZW Business - NO MotoMaker
    By evan_adams in forum Moto X
    Replies: 5
    Last Post: 12-05-2013, 09:29 PM
  4. Replies: 5
    Last Post: 12-05-2013, 05:43 PM
  5. OTA while rooted
    By Silent Infiltrator in forum Legacy Android & Other OS's
    Replies: 3
    Last Post: 12-05-2013, 12:14 PM