06-20-2011 10:32 PM
130 ... 3456
tools
  1. Joe8998's Avatar
    After I execute the "./rageagainstthecage-arm5.bin" command, the adb software no longer recognizes my droid device. When I run "adb devices", it finds no devices. I inevitably have to reboot my droid.

    Any advice?
    12-22-2010 05:05 PM
  2. darknight1580's Avatar
    This is exactly what happens to me, whether i use the one-click root or manually, the ./rage takes over 10 minutes to kick me back to the C:/ prompt, and adb is unable to connect to the device afterwards. At this point the phone basically locks up and I'm forced to pull the battery. I'm now starting to wonder if any apps running on the phone could matter. Any suggestions?
    01-12-2011 03:22 PM
  3. bigsmoove's Avatar
    This is exactly what happens to me, whether i use the one-click root or manually, the ./rage takes over 10 minutes to kick me back to the C:/ prompt, and adb is unable to connect to the device afterwards. At this point the phone basically locks up and I'm forced to pull the battery. I'm now starting to wonder if any apps running on the phone could matter. Any suggestions?
    same exact thing here... i dont get the lock up but it does slow to a crawl and i have to power on/off to get it back to normal smoothness. i only have pc's with windows 7, so i wonder if its a driver problem ... searching forums a bit, that seems to be a commonality.
    01-13-2011 09:16 AM
  4. KQCrackberry's Avatar
    Does this process work with the official 2.2.1 OTA?
    01-22-2011 02:57 AM
  5. Ugly Eddie's Avatar
    Too bad this doesn't work either.

    Must not be, meant to be...

    I get all the way to...
    " - ./rageagainstthecage-arm5.bin
    - let the process run until it 'kicks' you out (may take a minute or two) to C:\android-sdk-windows\tools
    - cd C:\android-sdk-windows\tools
    - adb kill-server
    - adb devices (to verify the connection) "

    No devices found. ADB.exe displays that it has to restart and connect to a port... but my device is not displayed/connected.

    Any ideas?

    Thanks.
    01-23-2011 10:05 AM
  6. anarkiss's Avatar
    I also can not see my device after I run the "./rageagainstthecage-arm5.bin" file. All forms of root fail out and I do not recieve the "#" symbol in shell mode.
    01-30-2011 03:49 AM
  7. neslot's Avatar
    at least you guys got that far. I type in "adb devices" after navigating to the tools directory and it says my device is offline. I can't go any farther. Any ideas for that?
    02-03-2011 05:08 PM
  8. DroidXcon's Avatar
    - let the process run until it 'kicks' you out (may take a minute or two) to C:\android-sdk-windows\tools
    - cd C:\android-sdk-windows\tools
    - adb kill-server


    can someone please explain to me why these steps are necessary...cd C:\android-sdk-windows\tools this seems pointless and redundant since it has already kicked you back to this directory

    and adb kill server, why is this necessary? im not exactly a newb , perhaps im missing something
    02-05-2011 03:27 AM
  9. DroidXcon's Avatar
    bumping the question above
    02-08-2011 12:47 PM
  10. LoveDroidX's Avatar
    ok i am new to all of this i have a Droid X for Verizon Wireless are there step by steps on how to Root it and why do i need to do that i would like to see a App to Root it for me lol Thanks for the help
    03-02-2011 09:39 PM
  11. deadlift425's Avatar
    Just an fyi, this can be downloaded from your phone using the browser.
    03-11-2011 09:30 AM
  12. dannymac77's Avatar
    edit, ok, scratch all, that, I was able to get it to recognize the phone only be rebooting it, but then adb shell still only brings up the $ prompt (not root) i run thru the rageagainst the cage portion and again, after typing adb shell, no devices found, until phone boot, rinse repeat... is this method no longer the preferred? I was noticing that the instructions were not updated to include that adb is now under the platform-tools folder, etc... please advise or lock unsticky if this method is no longer valid

    thanks!

    I get all the way to where it kicks you out to the C prompt
    Kill adb server
    then adb devices shows it, but as offline.

    Any idea how to get it back "online" ?

    I changed from Charge to PC Mode and back, no change
    Unplugged/plugged back in, no change

    battery pull: no change

    any other suggestions?
    04-04-2011 03:22 PM
  13. atticler's Avatar
    So i downloaded and installed Z4 Root on my DX, but everytime i press permanent root it stays on "Running exploit in order to obtain root access..."
    I've left it up for as much as ten minutes before. I tried rebooting it, and turning it off and taking out the battery, but it still loops.
    Any suggestions?


    EDIT:(Turns out, Kapersky was denying part of the file saying it was a trojan, i downloaded directly from my phone and all is well, currently running 2.3 rooted!)
    04-09-2011 11:26 AM
  14. rbgibson's Avatar
    Does this work on Android 2.3.340?
    04-15-2011 05:09 PM
  15. RHChan84's Avatar
    No it does not.
    04-15-2011 06:43 PM
  16. NewAge's Avatar
    Z4root? Sure it does. As long as 2.3.340 is still froyo and I'm pretty sure it is. For Moto DroidX. Might be mixing System Version and Android Version.

    Gingerbread is System Version 4.5.588... Android Version 2.3.3

    Froyo is System Version 2.3.340... And Android Version 2.2 and 2.2.1
    04-15-2011 07:54 PM
  17. davidnc's Avatar
    So i downloaded and installed Z4 Root on my DX, but everytime i press permanent root it stays on "Running exploit in order to obtain root access..."
    I've left it up for as much as ten minutes before. I tried rebooting it, and turning it off and taking out the battery, but it still loops.
    Any suggestions?


    EDIT:(Turns out, Kapersky was denying part of the file saying it was a trojan, i downloaded directly from my phone and all is well, currently running 2.3 rooted!)
    Just fyi:
    In your Kaspersky settings(KIS) not sure which version you have but still should have a "Threats and Exclusion" page you could have just added it to your exclusions,, and restore what it removed tho the settings ,,then it would have work
    But good you got it working
    Kaspersky does detect it as trojan tho.
    04-15-2011 08:56 PM
  18. RHChan84's Avatar
    Z4root? Sure it does. As long as 2.3.340 is still froyo and I'm pretty sure it is. For Moto DroidX. Might be mixing System Version and Android Version.

    Gingerbread is System Version 4.5.588... Android Version 2.3.3

    Froyo is System Version 2.3.340... And Android Version 2.2 and 2.2.1
    Yup. Forgot Android Version is different from System version. Whoops.
    04-15-2011 11:03 PM
  19. tdhondaex's Avatar
    So I go through the process and it hangs here waiting for device to show backup.
    [*] adb connection will be reset. restart adb server on desktop and re-login.
    Reconnecting in 20 sec...
    * server not running *
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    Checking for device...

    any help?
    04-22-2011 10:04 AM
  20. tgc201's Avatar
    I installed 2.3 but not my camera settings do not save after reboot. I am not rooted but I how to do I go back to the official OTA 2.2? I cant seem to find the file
    04-24-2011 03:11 PM
  21. smoorman's Avatar
    Excellent, thanks
    05-15-2011 11:07 PM
  22. bigdog777's Avatar
    New to the rooting world but down loaded a 1 click root app droidxroot.zip but it fails when it try to push the exploid file. I tried to do manually and it said the directory is a read only. All the other products have viruses. Help
    05-20-2011 07:10 PM
  23. jfrager's Avatar
    Thanks for the help, worked fine on my x.
    05-21-2011 02:53 PM
  24. radar320's Avatar
    I have a droid X and am running the leaked version of Android 2.3.3. I want to be able to receive the official update. Do I need to go back to Android 2.2 and if so, how do I do that? Any help would be appreciated.
    05-27-2011 03:30 PM
  25. tedtedted's Avatar
    Thanks for the work!
    05-30-2011 12:47 AM
130 ... 3456

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD