1. dvader's Avatar
    so i was testing some roms last night and ran into a problem.
    I have 2 good nandroid backup's and have always been able to just format everything and reinstall those.. no problems.

    I was running my setup and installed tranquility 2.3.7
    didn't really care for it. so i booted into recovery and installed "zapX"
    this started to install but then froze..
    so after several minutes, i did a battery pull and was bricked.

    I SBF'd back to 2.1 and everything was fine..
    i re-rooted and booted back into recovery.
    i tried to re-install my nandroid backup and it did work, but then when finished installing and rebooting, i would get stuck at the M

    I've never had this happend before.
    I have tried formatting everything and then installing.. i've tried it mounting system and not.
    i've tried to restore it every way i can think of and I always get stuck at the M

    I tried restoring last week's old nandroid backup and have the same issue.

    I thought that the nandroid backup was like a ghost image.
    ie no matter what i was running, the nandroid backup would restore the phone to a certain point.? is that not correct?

    I did not want to have to start from 2.1, re-root and re-upgrade everything.
    so i figured the nandroid back up was my shortcut.
    get to 2.1 (via sbf) root, install rom mgr and boot strap and then jump from that to my backup.
    that works.. but i get stuck at the M doing it that way

    any ideas?
    10-05-2010 10:36 AM
  2. jdivers03's Avatar
    Do you need to upgrade back to 2.2 using the leak before you're able to use those nandroid backups? I'm guessing you were running 2.2 when you created them?
    10-05-2010 10:52 AM
  3. dvader's Avatar
    that what i'm doing now..
    i think you are probably right.
    i just got done upgrading back up to 2.2 and am now restoring my nandroid backups.

    I guess they are not like ghost images
    we'll see if this works.. i suspect it will.
    thx

    edit - and it did!

    let that be a lesson to those whom play around
    10-05-2010 11:23 AM
  4. vor's Avatar
    What bootloader does it show now? 30.01?
    10-05-2010 11:27 AM
  5. dvader's Avatar
    yes 30.01
    but i can still sbf back to 2.1, i guess because i didn't install the 2.2 OTA
    I went 2.1 - 2.2 stock (i guess that's the .9 release) and then straight to the .15, i skipped the .13

    sooo in review
    if you brick and have to sbf back to 2.1 you MUST upgraded to 2.2 before restoring your nandroid backups.
    10-05-2010 12:33 PM
  6. vor's Avatar
    Yeah I had sort of bricked mine last night and couldn't figure out why the 2.2 sbf wasn't taking until I realized I had 30.01 bootloader so it wouldn't take the 2.2 image. sbf'd to the 2.1 and it worked first try
    10-05-2010 12:53 PM
LINK TO POST COPIED TO CLIPBOARD