1. ottscay's Avatar
    So I was beta testing something and it hosed my gallery. Does anyone know where I can get the gallery.apk for the 2.2.1 ota?

    Thanks!

    Sent from my DROIDX using Tapatalk
    12-15-2010 01:50 PM
  2. ragingxtc's Avatar
    if you have the 2.2.1 ota zip, you can pull it out of there. system/app/MediaGallery.apk
    12-15-2010 02:44 PM
  3. ottscay's Avatar
    Alas, that wouldn't install.

    Sent from my DROIDX using Tapatalk
    12-15-2010 04:25 PM
  4. JkdJedi's Avatar
    Might have to push that in via adb

    Sent from my DROIDX using Tapatalk
    12-15-2010 10:57 PM
  5. tntdroid's Avatar
    If you have terminal you can try that too.

    Sent from my DROIDX using Tapatalk
    12-15-2010 11:01 PM
  6. ottscay's Avatar
    Ugh, thanks guys. This seems like a good "teachable moment" for me to learn more about the inner workings, but it'll have to wait for a few days till I have the time to do proper research into it. I appreciate getting pointed in the right direction though!
    12-16-2010 01:00 PM
  7. ottscay's Avatar
    Ok, so I have terminal emulator installed, and the correct apk file. It's been a long time since I've used a linux terminal, anyone wanna throw me a bone with the proper commands to push the gallery apk to install?

    Thanks!
    12-20-2010 02:37 PM
  8. deSandot's Avatar
    BUMP! I need help on this too.
    01-03-2011 07:34 PM
  9. tntdroid's Avatar
    Ok, so I have terminal emulator installed, and the correct apk file. It's been a long time since I've used a linux terminal, anyone wanna throw me a bone with the proper commands to push the gallery apk to install?

    Thanks!
    Put apk file on root of sd card. Open terminal. Type su then hit enter. Then type install nameoffile.apk and hit enter. So if its labeled Gallery.apk it would be su enter install Gallery.apk enter

    Sent from my DROIDX using Tapatalk
    01-03-2011 09:12 PM
  10. Shade2074's Avatar
    Hi. Thank you for this post. I'm having similar problems on my motorola Atrix.
    I'm trying to reinstall my media gallery using the above method but when I do,
    I get the following:
    export PATH=/data/local/bin:$PATH
    $ $su
    #install MediaGallery.apk
    BusyBox v1.17.2 (2010-09-05 03:37:08 CDT) multi-call binary.

    Usage: install [-cdDsp] [-o USER] [-g GRP] [-m MODE] [SOURCE]... DEST

    Copy files and set attributes

    Options:
    -c Just copy (default)
    -d Create directories
    -D Create leading target directories
    -s Strip symbol table
    -p Preserve date
    -o USER Set ownership
    -g GRP Set group ownership
    -m MODE Set permissions

    #
    What am I doing wrong?
    03-27-2011 11:44 PM
  11. pool_shark's Avatar
    If I do a find for gallery several files.

    /system/app/MediaGallery.apk
    /system/app/MediaGallery.odex
    /data/data/com.motorola.gallery
    03-28-2011 10:13 PM
LINK TO POST COPIED TO CLIPBOARD