1. CarSalesman's Avatar
    I have a week-old DX, with the latest Froyo. The Z4 Root app will not work with this ROM, as discussed by many at forum.xda-developers.com where the Z4 Root app is supported (actually not supported...). Has anyone successfully rooted the latest DX ROM, either by manually typing shell commands or other downloads? Anyone tried SuperOneClick?
    03-12-2011 07:59 AM
  2. kismet769's Avatar
    Z4 worked on my X a couple weeks ago. Sometimes you have to give it a couple tries.

    The one click method didn't work for me the last time I tried it.
    03-12-2011 08:39 AM
  3. bear_lx's Avatar
    yea z4 is the only way to root in my opinion... if its not rooting your phone then there is a reason for it... so if i understand correctly, you have a droid x currently unrooted and running the latest version of froyo... you are trying to root with the one touch z4 method and it is unsuccessfull... ? if that is the case try wiping data/cache and then rooting... if you are going to be running any custom roms ( reccommend liberty 1.5 or apex 1.4.1) then you will have to wipe anyway. that should do the trick, if not then there has to be something else going on, hopefully you didnt download z4root from the marketplace, there is a fake method out there that is harmful to your phone...
    03-12-2011 09:02 AM
  4. Cyber Warrior's Avatar
    You may have a bad download of Z4root. Also sometimes Z4 doesn't stick the first time. Try installing it again.
    There's a download link for Z4 in this link and instructions: http://forum.androidcentral.com/moto...stom-roms.html
    03-12-2011 11:13 AM
  5. xliderider's Avatar
    Z4 should work on the .340 rom. It's the leaked Gingerbread rom that Z4 and, so far, any other root method does not work on.
    03-12-2011 02:27 PM
  6. droidxixis's Avatar
    z4root worked perfectly for me on froyo
    03-12-2011 03:27 PM
  7. judasmachine's Avatar
    I had to do a battery pull and run it a second time. The second time worked like a charm.
    03-12-2011 05:43 PM
  8. CarSalesman's Avatar
    I had been trying to root with RootMyX2. That would not work with my 2.3.340 DX. I ran Z4 which initially would not work, but with your suggestions I rebooted the phone and then Z4 worked fine. I suspect the reboot before Z4 is required because some application that may be already running interferes. Thanks.
    03-12-2011 08:58 PM
LINK TO POST COPIED TO CLIPBOARD