1. WhateverSofia's Avatar
    I have an Xoom2 and today, all of a sudden it shut down! I've tried everything: charging, holding the on/off button and the volume up button at the same time, holding all the buttons together at the same time and nothing happened! The weirdest part is that when I plug the charger the light won't turn on! Do you have any ideas of what else I could do?? I'm desperate :0 thanks!
    06-21-2012 05:15 PM
  2. brpaul's Avatar
    I just have the exact same problem !

    I tried to let it on charge during 1 hour.

    I did not downloaded new app

    Is it because of a silent OS update which has broken something ??

    I tried to use the Xoom Dock for the connector but still no charge.

    Just before the problem I tried to plug in a USB disk but the Xoom screen was already black. Nothing has never appeared on the screen. Do not know if this can be a cause of the pb.

    Help anybody ?
    07-12-2012 01:10 PM
  3. brpaul's Avatar
    Others informations :
    OS : android 3.2.2
    Xoom 2 Wifi only
    I used a Motorola charger
    system version : 0.268.4.MZ615.retail
    firmware : GAS_EMEA_USATBLT1WIRTFR_P006
    kernel :
    build : 1.6.0_268.4-MZ615

    I cannot see any led blinking (red, white, green or whatever) at the top or the bottom of the screen when pluging the charger and/or switching on the tablet power button.


    I found and tested with success a solution :
    - wait for a week to be sure the battery is 0%
    - press the 2 buttons for volume at the same time, then the power on button (all 3 together) during 5 s
    - release buttons
    - press on the power button : a red led blinks 3 times at the top of the screen (at right side of the web cam) then nothing more
    - plugin the motorola charger on the microUSB port.
    Do not try to charge the tablet using a USB connection to a PC.
    - a red led lights on at the top, and a white led lights on at the bottom. The screen remains black
    - after 5 minutes, the screen lights and shows the motorola logo. Then after few seconds it becomes dark again.
    - wait 5 minutes again
    - if you press on the power button, the screen displays a big battery icon and a level : 0%, then 5%, then 10%. Then the screen becomes dark again. It's ok, just wait.
    - after 5 mn more, press the power button : the level is 20%
    - wait 2 or 3 hours : the level reachs 100%.
    The bottom led light always remained white.
    - The top led light (red one) lights off somewhere between 20 and 100% charge level
    - plug off the charger
    - press the power button during 3 s : the motorola logo displays
    - then after around 12 s the screen with the lock is displaying. Touch it twice to log in.

    That's all folks

    I do not know what precisely went wrong (the motorola charger ? the OS crashed ??) but now it is working as usual.

    This procedure is not described anywhere on the net or into the user manual, and the motorola hotline does not know it, please share.

    Conscience Sociale
    07-20-2012 04:30 AM
  4. Jimmy Han's Avatar
    I had the same problem 3 months into this set, I send in the set and they simply replace the battery and the charging port. Now it works like a charm.
    12-14-2012 03:43 AM
  5. Jaezex's Avatar
    Please help my Xoom2 Media edition went blank on changing the wallpaper. tried rebooting, tried holding vol+up, vol+down, vol+ up + down. without success although the tablet did reboot but no display on the screen
    01-30-2013 07:23 PM
  6. BowlingF's Avatar
    mine did the same thing and I held down the power and nothing just blinks red 3 times what to do
    09-22-2015 01:55 PM
  7. heini71's Avatar
    red LED blinks three times:
    deeply discharged device, OS will not boot and therefore even the charging seems not to start.
    Had this several times.
    Plug in USB charger and plug cable in and out several times (I do this on the plug side, not on the Xoom2 to protect the USB port which is a bit fragile.)
    After several times it all of a sudden comes back to life again.
    alternative: open it up and change the battery from external (only if you have a LIPO charger! Battery may explode!)
    Hope this helps...
    03-24-2016 11:02 AM