1. roscko's Avatar
    I started noticing the the following oddities that leads me to think that a poor or malicious app is stealing the focus of my Xoom regardless of what I'm doing.

    -- When I play stored video and movies using RockPlayer Lite, the video would pause by itself after a random amount of time. The app didn't freeze, because I could tap play again to make it continue, but it keeps pausing by itself.
    -- When i used the default video player, the player would at random times pause and resume, causing a stutter in the video plplayback lasting for about one to two seconds.
    -- When using the default browser, I would be reading a lengthy ppage aand kkeeping my finger on the screen to continuously and slowly scroll down the page. However, again at random ttimes, my held down finger would lose the "grip" of the screen as if it thought i lifted my finger off the screen.
    -- When I push the power button to put it to sleep, it would turn off the screen. However occassionaly and randomly within a few seconds, the screen would automatically turn itself back on. Sometimes this would happen several times in a row as I struggle to force it to sleep.
    -- When I'm using the Match.com app and sending an E-mail to a contact, it would automatically force save my unfinished E-mail and return me to the previous menu within a few seconds and at random intervals, even though I didn't hit any command to save the draft or close the draft and when I'm still typing the E-mail out.
    -- When I have an Angry Birds level loaded and don't do anything on it for a few seconds, it would at random times pause the game and pop the side bar menu open.

    This is so very frustrating! I can use any help out there!
    11-06-2011 07:30 PM
  2. Genericmessage00's Avatar
    I indeed had something similar happen with my Droid x. It would take on a mind of its own! Random screen presses, waking itself up, putting itself to sleep. I just swapped it out, like I did with every one of my android handsets. Went through 5 Droid x's alone.

    Sent from my Xoom using Tapatalk
    11-06-2011 08:14 PM
  3. roscko's Avatar
    i spent a larger part of today thinking of a way to solve this problem.

    I went to the settings to the list of downloaded apps and individually forced close each one down the list and played a video to see if that stopped it from randomly losing focus. I repeated this for each app or small group of apps individually.

    Eventually, I force closed three apps in a group that stopped the problem! It was Logitech Alert, Klondike (a solitaire card game app), and Google Maps.

    Since I grouped those three together, I'm not sure which one is the culprit. I'm thinking Google Maps because I had Latitude enabled and automatically signing me in to places, like home, but it hadn't done one in a while. I suspect it froze or got stuck in a refresh loop that never succeeded and hence stealing focus from the other apps.

    After force closing it, I reopened those three apps again so that they would be in memory again to see iif I can recreate the problem, and it didn't repeat. I'm guessing the force close of Google Maps caused it to reset itself and now it works ok. Regardless, I disabled latitude on my Xoom to prevent the same problem from happening again.
    11-06-2011 11:37 PM
  4. bigslam123's Avatar
    Yeah, its google maps. I had the same thing happen to me when playing ShadowGun. It would pause about every 30 seconds. I disabled updating in Google Maps and the problem went away.
    11-07-2011 08:30 AM
  5. Aelassy's Avatar
    Thanks a lot for the help, this was driving me crazy. I am using samsung galaxy s II, disabling latitude solved the problem for me (after uninstalling at least a dozen apps).
    12-17-2011 03:32 AM
LINK TO POST COPIED TO CLIPBOARD