1. crxssi's Avatar
    Prior to the 4.1 update, I had used the new caching feature in Maps to cache much of the state. Instructions are here: How to Use Offline Feature of Google Maps in Android But after the 4.1 update, something strange is happening:

    1) First, when I tried to use Maps with no data connection, it would never load, it would just give a spinning circle forever.

    2) When I tethered to my phone, it immediately started and showed me maps that had to have been cached because everything was lightening fast.

    3) The interface for caching is missing? Before, if I long-pressed on an address, there was an option for "Precache map area". Now that is gone!

    4) There is only one option in "Offline and cache" under settings- "Clear all map tiles". Everything else is just gone. I used to be able to see and manage the saved areas.

    5) There is also nothing about cache in Settings->"Labs", just "Measure" and "Bigger Text".

    In About, it says this is version 6.9.2. Has anyone else had these issues?
    07-28-2012 08:52 PM
  2. sparksd's Avatar
    I have a WiFi Xoom on 4.1.1 so I took a look at this. The caching option on a displayed address is gone. Go to the menu selection at the upper right and on the pulldown there is a new option, "Make available offline". Select that and you then get the capability to select an area to cache.

    I turned off WiFi and my maps opened up without a problem.

    Dave
    crxssi likes this.
    07-30-2012 11:05 AM
  3. crxssi's Avatar
    I have a WiFi Xoom on 4.1.1 so I took a look at this. The caching option on a displayed address is gone. Go to the menu selection at the upper right and on the pulldown there is a new option, "Make available offline". Select that and you then get the capability to select an area to cache.

    I turned off WiFi and my maps opened up without a problem.
    Thanks. I knew that option was there, but there is supposed to be an interface that shows me all the areas I had already cached. Perhaps I lost all the cache after the 4.1 update?

    So I spent time trying to find out and was unable to find the massive store I had downloaded prior (several hundred MB). So I went into settings for apps for Maps and cleared cache and downloaded a new set of offline storage areas. Looks like it is working as expected now. Also killed it, turned off WiFi, and it worked perfectly. Not sure why they found it necessary to delete all "My Places Offline"!
    07-30-2012 06:32 PM
LINK TO POST COPIED TO CLIPBOARD