1. flarkysmoo's Avatar
    Motorola zoom WiFi 32gb.

    I am unable to access my 8 GB SD card. I see it in astro file mgr, but can't save to it or delete anything on it, or format the sucker... It worked at one point but I ended up having to copy the ROM to internal storage to flash jellybean. Any ideas as how I should proceed?
    08-22-2012 07:47 PM
  2. flarkysmoo's Avatar
    Also I can mount and unmount the ext SD card but that's it.
    08-22-2012 08:13 PM
  3. flarkysmoo's Avatar
    I also tried a 32gb card with the same results.

    Anybody have experience with this?
    08-23-2012 12:03 PM
  4. Castorshells's Avatar
    Make sure card is FAT32 format.

    You should try a different file manager as well.
    Joyce Murray likes this.
    08-25-2012 07:21 AM
  5. flarkysmoo's Avatar
    Yup, I formatted again to make sure it was fat32. I also used sd card formatter util. no luck either way. I get permission denied when I try to create a file or delete anything on the card. I pulled the card and put it on my desktop again and changed permissions to everyone full access. still same...
    08-27-2012 10:01 AM
  6. flarkysmoo's Avatar
    I also, at your recommendation, used 3 different file explorers, none were as powerful as astro, but they all had the same results.
    08-27-2012 10:02 AM
  7. stevebclarke62's Avatar
    Hi I had the same problem so I downloaded file manager HD from play store and now I can read,write and delete on the SD card
    08-28-2012 08:03 AM
  8. skeetch79's Avatar
    There is also a fix which entails (if rooted) using a root explorer to find the platform.xml file in /system/etc/permissions/

    Mount /system/etc/permissions as R/W

    Open the platform.xml file in text editor mode (as is found in Root Explorer), scroll down until you see the EXTERNAL_WRITE_STORAGE permission

    Add the following to this permission: <group gid="media_rw" />

    Save the changes to the file and reboot your Xoom.

    (xda-developers - View Single Post - unable to write files to external sd card)

    I had the same issue after updating to Jelly Bean and this fix resolved my issue. Titanium Backup was not working as well because I had my backup folder location set to my SD Card.

    Hope this helps.
    08-28-2012 12:12 PM
  9. pixelsyndicate's Avatar
    Uh... I had no clue the Xoom external sd was writable, except through usb cable, until I saw a custom bootloader do it... But i figured it was just slick hardware-level code. I had always know the Xoom external card to be 733...
    08-31-2012 06:34 PM
  10. Paul_1201's Avatar
    There's an app in the Play Store called SDCardXD written specifically for the Xoom to allow access to the SDCard on your Xoom.
    08-31-2012 10:25 PM
  11. ssteimke's Avatar
    Hi, I have a galaxy s3 and love the phone, but I have a couple issues that maybe you can assist me with. You seem very knowledgeable on writing software fixes for rooted phones.

    The problem I am having is that I liked using my EVO 4g as a mass storage unit when I connected it to my laptop via USB. It was really handy when I needed to open and alter files on my phone. Now with the Jelly Bean software, it does not allow me to save changes I have made to a doc on he External SD card! That is a big problem for me. I don't know why they would take that function away? Seems to be a step backwards in usage flexibility. Can you help?

    Scott Steimke
    12-17-2012 05:00 PM
  12. Saciid Caliashkir's Avatar
    Thanks stevebclarke62 for the tip that actually solve my problem; You rock dude!
    12-28-2012 02:12 PM
  13. akmisc's Avatar
    hi Saciid Caliashkir and stevebclarke62

    What is the exact name of the file manager?

    01-07-2013 03:42 AM
  14. Courtenay334's Avatar
    A bit frustrating. The SD card is in the tab but there are no instructions for viewing the sucker. The card, that is, or any of its contents. You suggest installing the "HD" app from the Play store. Sadly, a search under "HD" brings up DOZENS of Apps with the name HD embedded in them. Can you be more complete with respect to the name of this App? For example, HD File Manager, or, HD Resources, - something that would provide me with a fighting chance to actually find it. Thanks.
    02-06-2013 10:14 PM
  15. Theo Kusters's Avatar
    Hi, I have the same problem and have tried this but he sees a new start after he gives to SD / ... but do not see the files, anyone have any suggestion?
    09-23-2013 07:52 AM