1. mtanman's Avatar
    First post. These AndroidCentral forums have been helpful so I though I should share my experience. My Xoom Wifi (not rooted, running jelly bean) went dark. Wouldn't power up. Battery appeared charged, as the LED was green. I tried the power button/volume button restart to no avail. I used to have a droidx that seemed to constantly require a physical battery pull to revive it, so I thought "how about a xoom battery pull". After finding some xoom disassembly videos, I mustered enough courage to disassemble, disconnect the battery, and reassemble. Once reassembled, it worked!! I cannot say whether it was the physical battery pull or I inadvertently reconnected a loose cable, etc. Regardless, it worked!
    01-05-2013 01:38 PM

Similar Threads

  1. Want to root my phone but no USB access or won't power up.
    By bogey golfer in forum Motorola Droid X
    Replies: 3
    Last Post: 03-05-2012, 02:23 PM
  2. Did a battery pull cause my phone was locked up.. and...
    By Raptor5150 in forum Virgin Mobile Optimus V
    Replies: 7
    Last Post: 10-09-2011, 11:59 AM
  3. Google Music Beta wont show up on my Xoom?
    By aanasa in forum Motorola Xoom
    Replies: 21
    Last Post: 05-20-2011, 01:04 PM
  4. So my Xoom just died.
    By hypocaffeinemia#AC in forum Motorola Xoom
    Replies: 18
    Last Post: 03-15-2011, 04:21 PM
  5. Why is my Facebook app taking up so much memory?!
    By whitenack in forum Android Apps
    Replies: 1
    Last Post: 02-25-2011, 09:47 AM