06-14-2013 06:19 AM
34 12
tools
  1. Briansuperduper's Avatar
    Hi there, I've been unable to connect my Xoom to my home Wifi network. My Xoom detects the network, and sees it as having "excellent" strength, but when I hit connect, I get a message saying "obtaining IP address", and then, nothing. Any ideas? Thanks.
    02-28-2011 10:53 AM
  2. thedeceiver's Avatar
    Hi there, I've been unable to connect my Xoom to my home Wifi network. My Xoom detects the network, and sees it as having "excellent" strength, but when I hit connect, I get a message saying "obtaining IP address", and then, nothing. Any ideas? Thanks.
    Have you restarted your router?
    02-28-2011 10:58 AM
  3. Briansuperduper's Avatar
    Yep, just tried it, no luck. My laptop, printer and other items on the network are all back up and running. Any other thoughts? And, thanks for the help!
    02-28-2011 11:20 AM
  4. bigguy_132's Avatar
    Do you have enough IP addresses available? You may need to expand your DHCP so that you can hand out more IP's.
    02-28-2011 11:35 AM
  5. Briansuperduper's Avatar
    Yep, I believe so, from my router settings:

    DHCP Range: 192.168.1.64 - 192.168.1.253
    Allocated: 10
    Available: 180

    I've got 9 devices running at present. Thanks again!
    02-28-2011 11:40 AM
  6. radsaq's Avatar
    Did the Xoom synchronize your wifi settings from another Android device? If not, are you sure you entered the correct password/key?
    02-28-2011 11:48 AM
  7. bigguy_132's Avatar
    It may be worth entering some info in manually and trying it to make sure there is not an issue with your Wifi. What I do would do is this. I do not have my Xoom in front of me but there should be a way you can enter in information manually.

    Enter 192.168.1.253 as your IP address.
    Subnet Mask should be 255.255.255.0 (You can check this in the router config page as well)
    Gateway 192.168.1.1(?) Whatever your router page is

    DNS: you will need to pull this info out of the router config page enter these in.

    After doing these steps see if you can browse the internet. If you can't you may be having an issue with your Wifi on your Xoom.
    hXcpunk23 likes this.
    02-28-2011 11:58 AM
  8. Briansuperduper's Avatar
    Thanks all for the help, I'm up and running!
    02-28-2011 12:56 PM
  9. bigguy_132's Avatar
    Awesome did you end up putting the info in manually or what did you do to get it working?
    02-28-2011 01:46 PM
  10. Briansuperduper's Avatar
    It was a case of simple user error.
    02-28-2011 11:39 PM
  11. sheepy's Avatar
    Any help would be much appreciated.

    I can access wifi without issue UNTIL i try and access my own wifi at home.

    If I do automatica (DHCP) it will connect but I do not get data packets. (no internet access). On my other computers I get data packets so this is not an issue with the wifi or indeed the motorola xoom (because i can access other wifi connections).

    I have tried changing to static and inputting.

    Example. my other computers static and working fine

    192.168.1.7
    255.255.255.0
    192.168.1.220

    8.8.4.4
    8.8.8.8

    Therefore, logic would tell me if i forced the MX with below but won't connect at all. Have tried

    192.168.1.8
    255.255.255.0
    24 (network prefix length)

    8.8.4.4
    8.8.8.8

    Above, it isnt even interested in connectings. Whereas when automatic it connects but no data packets (no internet access).

    My wifi setttings are

    medium (WEP 64bits)
    and yep putting in the correct password.

    I am at a complete loss. If someone can see the obvious I would be extremely thankful. Regards Sheepy
    03-02-2011 02:47 PM
  12. bigguy_132's Avatar
    Are you inputting the Default Gateway when it is static? The only other thing I can think of is that with DHCP you are not sending which DNS you are supposed to be using. Otherwise I am not too sure whats going on, I may need to sit and think on this one.
    03-02-2011 03:19 PM
  13. sheepy's Avatar
    When entering static it does not want to connect. Below is correct. I have these settings for my laptop and netbook computer working of same wifhi



    192.168.1.8 (ip)
    255.255.255.0 (gateway) i have tried (192.168.1.1) and (192.168.1.220) ..
    24 (network prefix length)....maybe 24 is issue?

    8.8.4.4 (DNS1)
    8.8.8.8 (DNS2)


    See my wifi settings that connects to a hotspot and i then use my wifi to wireless my location for my laptop, netbook and MX (all bot MX works). I have the asus WL-330g portable wireless.
    2011-03-02_2232 - Markscreencast's library
    03-02-2011 04:34 PM
  14. bigguy_132's Avatar
    Hmmm your gateway should be whatever your connecting to. So if its your router it would be 192.168.1.1. The 24 network prefix length is correct this would mean that it would take the subnet mask of 255.255.255.0 since it is 192.168.1.1/24.

    When entering static it does not want to connect. Below is correct. I have these settings for my laptop and netbook computer working of same wifhi



    192.168.1.8 (ip)
    255.255.255.0 (gateway) i have tried (192.168.1.1) and (192.168.1.220) ..
    24 (network prefix length)....maybe 24 is issue?

    8.8.4.4 (DNS1)
    8.8.8.8 (DNS2)


    See my wifi settings that connects to a hotspot and i then use my wifi to wireless my location for my laptop, netbook and MX (all bot MX works). I have the asus WL-330g portable wireless.
    2011-03-02_2232 - Markscreencast's library
    03-02-2011 05:52 PM
  15. sheepy's Avatar
    i entered

    ip address 192.168.1.12
    gatway 192.168.1.1
    network prefix length 24
    dns 8.8.4.4
    dns 8.8.8.8

    no luck. I think I have tried every combination.

    Thank you for your time, if you could just persevere with me, i would be very grateful if you were able to resolve. Thanks
    03-02-2011 11:10 PM
  16. sheepy's Avatar
    just got it!!! Thank you!!!!!

    Worked with

    192.168.1.12
    192.168.1.220
    24
    8.8.4.4
    8.8.8.8
    03-02-2011 11:13 PM
  17. bigguy_132's Avatar
    Glad to hear it!
    just got it!!! Thank you!!!!!

    Worked with

    192.168.1.12
    192.168.1.220
    24
    8.8.4.4
    8.8.8.8
    03-03-2011 07:47 AM
  18. cleis's Avatar
    just got it!!! Thank you!!!!!

    Worked with

    192.168.1.12
    192.168.1.220
    24
    8.8.4.4
    8.8.8.8
    I'm having the same issues with my router at home. I imagine I will use similar settings, but am not 100% sure and wondered what steps I can use to determine the proper settings to create the static IP. Thanks.
    03-29-2011 09:30 AM
  19. bigguy_132's Avatar
    I'm having the same issues with my router at home. I imagine I will use similar settings, but am not 100% sure and wondered what steps I can use to determine the proper settings to create the static IP. Thanks.
    You will use similar settings correct. Please login to your router at home and post what your DHCP range is. Most of your settings though are probably going to look like this

    Static IP: 192.168.1.150 - Just pick something out of your DHCP Range of this. So if your DHCP range is 1.10 - 1.25, you can just use 192.168.1.26 (static ip)
    Subnet Mask: 255.255.255.0 (This is also defined in your router config page and should be listed as subnet mask)
    Default Gateway: 192.168.1.1 (this will be whatever you go to to login to your router.)

    DNS Server 192.168.1.1 or you can use googles of 8.8.8.8 and 4.4.4.4
    cleis likes this.
    03-29-2011 12:11 PM
  20. cleis's Avatar
    You will use similar settings correct. Please login to your router at home and post what your DHCP range is. Most of your settings though are probably going to look like this

    Static IP: 192.168.1.150 - Just pick something out of your DHCP Range of this. So if your DHCP range is 1.10 - 1.25, you can just use 192.168.1.26 (static ip)
    Subnet Mask: 255.255.255.0 (This is also defined in your router config page and should be listed as subnet mask)
    Default Gateway: 192.168.1.1 (this will be whatever you go to to login to your router.)

    DNS Server 192.168.1.1 or you can use googles of 8.8.8.8 and 4.4.4.4
    Thank you! I won't be home to look them up until tomorrow night, but will post them then.
    03-29-2011 04:41 PM
  21. crxssi's Avatar
    When I first got the Xoom, it connected fine to my WRT-54GL wireless. But a few days later it kept getting stuck on "obtaining IP address". I power cycled the Xoom- nope. I tried everything on the Xoom- nope. My Android phone was fine, so was my Wii. So I went into the Linksys and deleted the DHCP entry for the Xoom and for one other unknown/unnamed device and then tried to reconnect on the Xoom and it worked fine. I hope this is not "normal", since I have been using this router and WiFi devices for years without issue.
    03-29-2011 08:40 PM
  22. bigguy_132's Avatar
    When I first got the Xoom, it connected fine to my WRT-54GL wireless. But a few days later it kept getting stuck on "obtaining IP address". I power cycled the Xoom- nope. I tried everything on the Xoom- nope. My Android phone was fine, so was my Wii. So I went into the Linksys and deleted the DHCP entry for the Xoom and for one other unknown/unnamed device and then tried to reconnect on the Xoom and it worked fine. I hope this is not "normal", since I have been using this router and WiFi devices for years without issue.
    Odd did you have a static IP defined for your Xoom in your router page? If not try lowering your DHCP lease time, that way it clears your lease out faster. Most of them are set for a day(?) you could try lowering that to 6 hours to see if that clears up this issue.
    03-30-2011 08:52 AM
  23. cleis's Avatar
    You will use similar settings correct. Please login to your router at home and post what your DHCP range is. Most of your settings though are probably going to look like this

    Static IP: 192.168.1.150 - Just pick something out of your DHCP Range of this. So if your DHCP range is 1.10 - 1.25, you can just use 192.168.1.26 (static ip)
    Subnet Mask: 255.255.255.0 (This is also defined in your router config page and should be listed as subnet mask)
    Default Gateway: 192.168.1.1 (this will be whatever you go to to login to your router.)

    DNS Server 192.168.1.1 or you can use googles of 8.8.8.8 and 4.4.4.4
    Thanks for the help on this, but it was 100% user error on my part. I had written down the router password incorrectly. After fixing that, it worked just as it should (IP assigned via DHCP)
    03-30-2011 07:44 PM
  24. wpaeb's Avatar
    Having a WiFi issue with my 3g xoom. My work network uses static IP's. I've had my xoom for a month and it works most of the time.
    Today it would not hookup to the internet. I checked settings and it was on DCHP instead of static. So I modified the settings to static. Still no connection and when I checked settings it was DCHP.
    Then I told it to forget the network. Reentered it in static, hit connect, checked and it DCHP again. Then I told it to forget again. Restarted reentered in static. Same result. I catch a quick glimpse of "changing IP" message when it connects.
    I also have no idea where it's pulling the IP from. It's the correct network, just not in the range of my router so no DNS info. My laptop works fine and so does my webos phone.
    04-06-2011 10:00 AM
  25. crxssi's Avatar
    Odd did you have a static IP defined for your Xoom in your router page?
    No.
    I am still having lots of problems with the Xoom and only the Xoom. Additional people are reporting this behavior in other forums now, too. This morning, I rebooted the Xoom to try and get a connection and still could not. If I go into the "DHCP Clients Table" and delete the entry for the Xoom, which is named "android_b0159a526488e38b", then I can connect the Xoom again immediately.

    If not try lowering your DHCP lease time, that way it clears your lease out faster. Most of them are set for a day(?) you could try lowering that to 6 hours to see if that clears up this issue.
    It was set to "0" minutes, which is one day. I just changed it to 240 min (4 hours) will see if that helps or makes it worse.
    04-10-2011 09:38 AM
34 12

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD