1. AC Question's Avatar
    I haven't used it much for years except here and there. But I want to start using it again and also to root it now that I know how, after switching from iPhone to Android.
    So I found it, I tried to power it on. Nothing happened, not even the red light at the bottom. So I thought maybe it's so dead that it won't even flash the light (?) ...I couldn't find my charger so I plugged in the USB connecting it to my computer. Nothing still. I tried the volume up with power on. Nothing. I even tried for a full 30 seconds, still nothing.
    Is it likely completely broken? Is there anything I can do?
    07-15-2016 12:03 PM
  2. pkcable's Avatar
    Completely drained of power and does not have enough power to get the charging cycle going. Do you get ANYTHING at all when you plus it in? Does the light flash on at all? If so you MIGHT try stack charging, which is letting it get that little blast of charge OVER and OVER until it has enough power to start the charging cycle. Doesn't work all the time. IF you want to try it, the easiest way is to plug the power cord in to an unused power strip with an on/off switch, then plug in the Xoom. Turn on the power strip, wait 3 seconds, turn it off, repeat, etc like 200 times, THEN just plug it in and let it charge IF you get a steady charge light. MIGHT NOT WORK!
    07-15-2016 12:15 PM

Similar Threads

  1. How do I allow cellular streaming on a Sony Xperia Z3?
    By AC Question in forum Sony Xperia Z3
    Replies: 4
    Last Post: 08-20-2016, 08:24 PM
  2. Replies: 4
    Last Post: 07-18-2016, 12:35 AM
  3. Replies: 3
    Last Post: 07-15-2016, 12:10 PM
  4. Google now on tap not on
    By samoldland_123 in forum Ask a Question
    Replies: 0
    Last Post: 07-15-2016, 11:48 AM
LINK TO POST COPIED TO CLIPBOARD