1. LMO's Avatar
    After installing Titanium Backup (paid version) I discovered that it was backing up some system data but none of my apps. I was so frustrated and tried everything I could think of. Finally I found the solution. If anyone else has also had this problem, here is the solution that fixed this problem:

    Titanium Backup installs Busybox version 1.16. This did not work on the Xoom. I installed Busybox version 1.18.4, and after that, Titanium worked perfectly!

    Here are the step-by-step instructions, and also the Busybox v1.18.4 file in case you need them:

    1. Using a root file explorer, go to the folder "/data/data/com.keramidas.TitaniumBackup/files", and rename the old busybox file to something like "busybox.old" (I renamed mine to busybox_1_16, so that I know which version it was. You could also just delete the old busybox file, but I choose to just rename it.)

    2. Get the attached "Busybox.zip" file I have attached here... make sure to unzip it on your computer first before copying it to the Xoom.

    3. Copy the new busybox file to the "/data/data/com.keramidas.TitaniumBackup/files" folder.

    That's it! Titanium Backup should work fine now and show all your apps.
    04-17-2011 11:40 AM
  2. wjouqd's Avatar
    Thanks. I am faced with the same problem. I will try the 1.18.4 version.
    05-24-2011 03:53 AM
  3. mbroeders's Avatar
    Nice post!
    But you could also install busybox installer from the market which allows you to easily install 1.19 (latest version). Then restart Xoom and TB will work properly...
    05-24-2011 05:41 AM
LINK TO POST COPIED TO CLIPBOARD