1. criplord187's Avatar
    I apologize if this has already been posted. But I've got a mytouch 3g slide. accidentally manage to break my digitizer. This isn't the first time it's happen It's happen once before. The first time I ordered a new digitizer took the phone apart replaced the old for the new one put the phone back together it worked exactly the way it should. Anyways this digitizer broke, so I as I did before I ordered a new one once again took the phone apart as I did before. I replaced the broken digitizer with the new one. Put the phon backto gether. Only this time when I turned the phone on it vibrated upon turning on the way it usually does but this time the screen was blank. So thinking I may have possibly missed attaching something that should've been I took the phone apart again and made sure things were in order and they appeared to be. So I tried it again once again blank screen upon turning it on. So I for a third time took the phone apart to inspect each piece. Now from the way it looks to me the little flex cable attached to the lcd display has a small sever all of maybe a millimeter. So thinking that I had somehow managed to ever that cable I ordered a new lcd display. I get the new display and take the phone apart yet again and replaced the old lcd with the new one. I then put the phone back together hoping my problem has been resolved. But upon turning the phone back on once again it made the vibrating noise but still the blank screen. Could or does anyone possibly have an idea as to what I can do? Sending my phone to t-mobile isn't and option my phone is past its warranty. Yes I 've got the insurance plan for the phone but if I were to go and spend that much to get the phone replaced at that rate I would be better off spending a little more money on a whole new phone altogether you. Also another question if anyone also may have any suggestions for this either my center sensor button that makes the display appear as well as my home button and settings button do not work. The back button and the genius buttons both work but the other 3 do not any suggestions for this? This was happening prior to the breaking the digitizer. Yes I tried resetting the phone two different ways one via settings a factory reset and then the other by turning the phone off holding the volume button down truning the phone on in recovery mode and resetting the phone that way and still the button prolem persists. Any suggestions?
    07-16-2012 07:51 PM