1. androidfrog's Avatar
    Thanks for allowing me to post a question on this Forum; great interface and what looks like plenty of knowledgeable people!

    I have been a Sprint corporate customer for decades (and a miserable stockholder for years ) but yesterday I decided to upgrade my old faithful Moto-Q to a "fancy" Kyocera Echo.

    Great service at the store, the unit works just fine in terms of battery life and works as it supposed to do, but today while looking at the Sprint & Kyocera sites I notice that there is an upgrade available for Android 2.3.4 "Gingerbread" that will add some useful interface functions as well as the "eco" widget that both seemed like a good idea.

    I did the upgrade without any problems. All functions worked as promised, however I noticed that when I connect the Echo to the charger, rather than getting a solid red light I now get an "erratic" red light, sometimes flashing slow (about once per second), sometimes faster (about half-as-much) and sometimes just a blink.

    If I power off the unit and keep it on the charger; I get a solid light right away and within 20' it's a solid green. While keeping the device plugged in if I turn it back on the green light shows the same erratic flashing pattern...

    There are no notifications in the system and I removed the "eco" widget. No change.

    I called Sprint Tech Support, the person was nice, told me to remove the battery for a full minute, "refreshed" the phone, and called back to see if it worked, however the answer was "no"... the charging light still flashes without a specific pattern. At this point the advice I got was to make sure that I use the 15 day return warranty and go back to the store for an exchange...

    I guess that's what I may have to do, but here are my questions. Thanks in advance for any input:

    1) is this a documented bug with Android 2.3.4 for the Echo?
    2) I like this phone, but did I simply get a lemon? I don't mind having it replaced but I would hate to do this if it means more bugs....

    Thank you for whatever information and/or advice you may offer!
    10-10-2011 10:13 PM
  2. androidfrog's Avatar
    The flashing light issue that I described in my previous post is solved! The problem was with the charger and not with the phone... In order to save some space on an AC outlet I was using an aftermarket USB charger with two USB plugs, one for my iPod and one for the Echo... After some frustration with being unable to solve this erratic blinking light, I decided to listen to some music but noticed that my iPod was not fully charged, even after being plugged for more than 2 hours... As soon as I disconnected it from the charger, the charging red light on the Echo became solid and within 15 minutes I had a solid green light!

    The charger that I used originally was a Duet "MusicPower" that has two USB ports rated each at 5V/500 mA but this was not enough for the Echo... the charger that came with it is rated at 5V/800 mA and that's a substantial difference in output! I should have remembered that not all USB chargers are created equal as my old Moto-Q chargers are 5V/850 mA!

    Anyway, things look just fine now as far as charging is concerned!
    10-11-2011 09:27 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD