1. Cornfield's Avatar
    I have an LG G2 D802

    It is rooted but I did not have a custom ROM installed when I decided to try and get the legit Android 4.4 kitkat update from LG. The thing downloaded but when it tried to install it went to my TWRP screen. Then nothing worked. I panicked and decided to do a wipe. So basically now I have no OS. I tried entering download mode but that did not work. I tried restoring an old backup I had on my phone, that did not work. I finally got somewhere after I pushed the cm11 ROM on to my phone using ADB. Everything seemed to work fine with the push and I installed the ROM in TWRP but when restarting the phone it just goes back into the TWRP menu. I do not know what to do. PLEASE HELP!

    p.s quite new to this, so try and explain everything in detail
    04-01-2014 02:14 PM
  2. SactoKingsFan's Avatar
    This guide shows how to return to stock firmware.


    Sent from my LG-G2 running Carbon
    04-01-2014 02:31 PM
  3. Cornfield's Avatar
    Thanks for replying so quickly. I have seen your reply on other threads and I have tried to follow that site but it does not seem to work. Also says that one of the files contain a malware....Like I said, that guide did not work for me. The file that supposedly contains malware btw is LG_KDZ_FW-Update_OfflineFix

    Again, thanks but I have tried to follow the guide and at least for me it did not work.
    04-01-2014 02:58 PM
  4. James Dean4's Avatar
    I have this exact issue. I was using slimkat rom then decided to flick back to a nandroid recovery for some dumb reason. soon after it started downloading an update. I had heard you shouldn't install ota upgrades with a custom recovery but when it prompted me I had a blonde moment n just hit ok. Now it boots into twrp. I can install my nandroid or slimkat backup but it still boots to twrp. I have wiped everything multiple times but still won't fire up. Ill keep you posted if I find a fix

    Here is the fix. I used option two which took all of about 10 seconds (cant believe it was so easy) I had wiped the phone earlier so when it was fixed It had no OS and wouldn't get past the LG logo. I had to do the volume down + power button factory reset which booted back into TWRP. From there I sideloaded a custom rom (Slimkat) and it booted up. Hope this helps someone. I sure learned my lesson about not taking OTA's with a custom recovery.
    Cornfield likes this.
    05-04-2014 03:08 AM

Similar Threads

  1. Replies: 112
    Last Post: 06-30-2014, 02:31 AM
  2. I think my Sprint S4 SPH-L720 is very close to hard-bricked
    By Obamaphone in forum Samsung Galaxy S4 Rooting, ROMs & Hacks
    Replies: 2
    Last Post: 04-05-2014, 03:26 AM
  3. Root for LG G2
    By TouchPerception in forum LG G2
    Replies: 4
    Last Post: 04-05-2014, 01:50 AM
  4. G2 Mini on Sprint
    By PxuLL in forum LG G2 mini
    Replies: 3
    Last Post: 04-03-2014, 01:13 PM
  5. vzw lg g2 no gas no recovery
    By grandpa22 in forum Verizon LG G2
    Replies: 3
    Last Post: 03-31-2014, 07:15 PM