1. chainsawsakura's Avatar
    Hey guys! I've been trying to solve my issue for a few days now, but hopefully you guys can help me out.

    I recently bought a 30000 mah power bank off of Ebay. It's identical to this one - Amazon.com: black 30000mAh External USB Battery Charger High Capacity Power Bank for iPhone ipad samsung: Cell Phones & Accessories. It will charge my husband's S2 on ATT and our camera with the same cable, but not my phone. I've tried every USB cable I have in the house - I haven't tried the one it came with because I somehow lost the connector pieces already - It's one of those deals were you can fit whatever connector onto it that you like.

    Are some power banks incompatible with the Nexus 4? Or do I need a different kind of cable? I'm trying to find the little pieces, but I really don't like them in the first place. Any tips/suggestions?
    07-08-2013 06:56 PM
  2. pontiac005's Avatar
    Did you take a look to make sure the little prong inside the N4's connector is not bent? I have read in the past if it gets bent, it will not charge properly. Did that to me once and I took a small screw driver and lifted it up a bit. Never had a problem again.

    Sent from my Nexus 4 using Tapatalk 2
    07-08-2013 08:34 PM
  3. chainsawsakura's Avatar
    Well my phone charges fine when I plug my cable into a wall or a computer, so I know my phone is otherwise charging fine. It just won't work with the power, which clearly works.

    I've been reading about 5 pin and 4 pin micro USB. The cable I have is a 5 pin - would getting a 4 pin do anything?
    07-08-2013 08:55 PM
  4. pontiac005's Avatar
    I don't know, but if you do try it and it doesn't work, make sure you can return it. If possible, go to a local place and see if they will let you try it out before you purchase.

    Sent from my Nexus 4 using Tapatalk 2
    07-09-2013 09:26 PM
  5. Raneka Stevens's Avatar
    I would return that charger and go for the limeade blast it works with every device I have. Check out this video

    08-08-2013 04:12 PM
  6. Bett15's Avatar
    Try out with CHOE Qi Wireless package from amazon
    09-09-2013 05:38 AM
  7. N4Newbie's Avatar
    From what I see on the Amazon listing, the device has two USB ports, Port A and Port B. Port A is rated at 1000mA and Port B at 2100 mA. The stock Nexus 4 charger is a 1200 mA (1.2 amps) unit. Which port have you been testing with? Have you tried the other with the same result?
    09-11-2013 02:06 PM
  8. Erwin Gaa's Avatar
    I have the same problem with my powerbank. I was reading somewhere, that google changed some wiring on the micro usb so it only will work with their power banks. I think I will try to get a wiring schematic so I can figure out where the plus and where the minus is located on that usb port and then make my own cable out of old stuff. Just telling you, you are not alone
    03-05-2015 12:54 PM

Similar Threads

  1. charging phone and using OTG capabilities simultaneously
    By coreymac08 in forum Sprint Samsung Galaxy S4
    Replies: 2
    Last Post: 10-28-2013, 02:55 PM
  2. S4 Active stopped working after placing in a bowl of water.
    By milehigherik in forum Samsung Galaxy S4 Active
    Replies: 27
    Last Post: 07-10-2013, 05:43 PM
  3. brand new battery takes a while to work properly?
    By thewango in forum Google Nexus 4
    Replies: 6
    Last Post: 07-09-2013, 11:11 AM
  4. Not charging on car or laptop cables
    By jeffrok in forum Droid RAZR MAXX
    Replies: 4
    Last Post: 07-08-2013, 11:29 PM
  5. Power on/off
    By donb2010 in forum Verizon Galaxy Note 2
    Replies: 4
    Last Post: 07-08-2013, 10:16 PM
LINK TO POST COPIED TO CLIPBOARD