1. JohnnyBroccoli's Avatar
    towelroot by geohot

    So....famed hacker GeoHot just released a one click root .apk yesterday. Apparently it should work with the Nexus 5 as well as just about any Android device with a kernel from earlier than June 3, 2014. Just trying to start a conversation about this root tool. I have yet to root an Android device and this might be just the thing to get me to do so finally. Jailbroke every iPhone I owned but haven't felt the strong need to root my Nexus 5. Though I am very interested in Greenify and some sort of app to trick the internal GPS so I can view blacked out games of my local baseball teams via the MLB At Bat app.

    If anyone has successfully rooted their device with this tool (and more specifically on 4.3.3), I'd love to hear how it went. I'll chime back in if/when I do so. Was hoping to get confirmation that this definitely works with the Nexus 5 on 4.3.3 before making the plunge. Pretty sure it will but yeah, just trying to be careful....
    06-16-2014 07:25 PM
  2. JohnnyBroccoli's Avatar
    No comments at all? Geez....guess I'm better off sticking to that other forum.
    06-17-2014 01:42 AM
  3. gerland hardin's Avatar
    Does NOT work on Verizon Note 2 running 4.4.2!!! Not at all and he doesnt get back too you like was posted in XDA.
    06-18-2014 12:30 PM
  4. JohnnyBroccoli's Avatar
    Okay. So did it just reboot without root or did it bring you some troubles?
    06-19-2014 03:11 AM
  5. stridr69's Avatar
    I rooted yesterday with an 18 month old Droid Razr Maxx HD. Worked like a charm. And I'm on 4.4.2 as well. Far easier than jailbreaking my iPhone 3G back in the day. It's nice not having all of that Verizon bloatware on the phone anymore. I say "Go for it!".
    06-19-2014 09:28 AM
  6. antilles76's Avatar
    I can confirm that it works on the Nexus 5. Did it earlier today. You need to make sure to install supersu once rooted and it is suggested to install a custom recovery thru Flashify. Both SuperSU and Flashify are avaliable for free on the Play Store.
    06-19-2014 01:07 PM
  7. burrari's Avatar
    The same with me worked and super simple no problems just follow what he said about installing those apps. I didn't go custom rom just yet just loaded xposed to customize it a little.

    Posted via Android Central App
    06-20-2014 06:13 AM
  8. qfnol31's Avatar
    towelroot is really awesome. I've used it twice now without any trouble and it's quick, without a reboot even.
    06-27-2014 03:49 PM
  9. VAVA Mk2's Avatar
    I find WugFresh's Toolkit to be easy and always updated to the latest version. This might be cool though.
    ConTejas likes this.
    06-29-2014 06:37 PM
  10. Shawn Magm's Avatar
    I used Towelroot on mine (Android 4.4.4), and it was so easy. I confirmed the root status with the root checker app. I installed Greenify and also ROM Manager with Clockwork and Samba fileshare. However, my battery life started dropping 2-3% every hour or more. I uninstalled ROM Manager and Samba Fileshare, and now my battery life is back to its baseline pre-root. Not sure if it was ROM Manager or Samba that was causing the drain. I'm new to rooting, so I'm still in the learning process as to which apps to install to take advantage of root.
    07-04-2014 03:55 PM
  11. ol chap's Avatar
    Never rooted before, have read a lot about it but never done it because I've only got one device right now downloaded towelroot pushed the button and nothing happened asides a small pop up saying "you are now rooted" and everything works wonderfully now just installing a custom recovery and then the fun with xposed framework will begin! Lg g2 D800[20u]

    Posted via Android Central App
    07-04-2014 04:34 PM
  12. jball32's Avatar
    I used fastboot/adb on my Nexus 5 but I have use towelroot on my ladies skyrocket and a friends us cellular S3 and was fast and easy

    Nexus 5 via Tapatalk
    07-12-2014 03:25 PM
  13. vandeleigh's Avatar
    I used fastboot/adb on my Nexus 5 but I have use towelroot on my ladies skyrocket and a friends us cellular S3 and was fast and easy

    Nexus 5 via Tapatalk
    Do you know what OS was on your friends US Cellular S3? I ask because I just tried towelroot on my S3 running 4.4.2 and nadda. I hit the "make it rain" button and it says "this device not supported"....

    back to the drawing board.
    08-03-2014 10:54 PM
  14. Surfer Joe1's Avatar
    GS5 w/ 4.4.2 and build earlier than June 4, used towelroot BUT a few days later the S5 started throwing errors and the radio went dead, could not revive it after trying many things. Uninstalled a few of the latest apps then tried safe mode, no luck. Backed the data up then jumped in with both feet and did a factory reset, no joy. "unfortunately cell.android.phone stopped working" and "unfortunately settings stopped working" kept coming up. Luckily it's under warranty so I'll try that to get restarted.

    The rooting went fine itself, too bad, I was enjoying that. I'll have to wait around for v2.0 that can handle post June 4 builds.

    In any case, GeoHot did a fine job with this public service, nice job programming using the exploit that takes advantage of the rooted state after causing a deliberate crash, all impressive work.
    08-14-2014 01:22 AM

Similar Threads

  1. Towelroot Method of rooting
    By designwebs in forum Ask a Question
    Replies: 1
    Last Post: 06-27-2014, 10:30 AM
  2. Towelroot Method of rooting
    By designwebs in forum Ask a Question
    Replies: 1
    Last Post: 06-26-2014, 12:04 AM