1. Cameron Dew1's Avatar
    Hi all,
    I've been trying to root the nexus 5x recently with the NRT, and it's been a nightmare. I tried it with all relevant drivers installed ADB/fastboot and the composite drivers, superSU that is the latest for the 5x and busybox, with the bullhead custom recovery. I have tried several times to get it to work but after rooting it, it always comes up "unable to mount storage" and that the disk image patcher (don't recall of memory can't see it in lof) failed and is aborting.

    It does not show it rooted in the SuperSu app on android either. To fix the available online for the storage mount issue, no luck. It doesn't actually show 0mb storage it shows the correct amount on twrp but still won't mount, keeping in mind I am fairly new to the android operating system and have never really rooted before. And yes I have backed everything up with the toolkit to my laptop.

    The "!readytoroot" folder is also missing from setup, which is why busybox and maybe SuperSu hasn't properly installed, then again before when I did install it correctly it still didn't work.

    Any ideas? I appreciate this is just basic info but I'd be happy to share more.
    https://imgur.com/a/QguEiNj
    12-19-2020 01:27 PM
  2. Cameron Dew1's Avatar
    Would really appreciate some help here...
    I've tried to install quick reboot (zips), magik, (zips) and busybox, on 3.4 0-0 twrp, and it won't work to boot to system, still says on this version it cannot mount the system. I don't have the perma-recovery file as I cannot find it online, and nexus root toolkit doesn't download it in the dispensaries, latest version.

    Hope I haven't knacked it, i also have some screenshots but it doesn't matter as I cannot access the system itself, unless i am missing something it should just boot back to system, I don't understand what I am doing wrong, or have done wrong. Got the img and everything with it.

    That said, the mount storage issue is the only thing red, or wrong in the flash, everything else worked apparently, said it installed without a hitch. Which was different that with the standard NRT downloaded twrp, with supersu, as that didn't work.

    It just goes back to twrp constantly, can't boot. Help. Really wish I just waited for a response here first. Also I don't believe this is a bootloop, as it just goes back to twrp not bootloader or anything else, probably wrong.

    I have been using this vid from the start: realizing that wasn't doing it, magik and a new bionic busybox zip eventually did the trick on 3.4 0-0 twrp, but it sitll won't boot to system. It is probably something obvious, I have been on this for hours today and yesterday, no luck.

    only thing i can think of is something to do with: fastboot flash recovery twrp-3.2.1-0-fbe-4core-bullhead.img
    basically i flashed the latest version, i dunno if it's supported by nexus 5x.

    thanks.
    12-19-2020 05:48 PM
  3. mustang7757's Avatar
    Hi welcome to AC!

    I think best place to ask is xda forums they are more geared towards rooting
    12-19-2020 06:15 PM
  4. Cameron Dew1's Avatar
    i copied this and posted it there. any one have any ideas though.
    12-19-2020 06:20 PM
  5. mustang7757's Avatar
    We see if any members might know, but from my experience here in forums most don't bother with rooting much anymore.
    12-19-2020 06:33 PM
  6. mustang7757's Avatar
    Let me tag this member , he roots his pixels and might know @Rukbat
    12-19-2020 07:07 PM
  7. Rukbat's Avatar
    Try rooting with Magisk. All you have to do is grab the boot.img file from the last update (Factory Images), install Magisk Manager, tell it to modify the boot.img file, copy the modified file to the PC, then flash the boot image. (It takes as long to tell about it as it takes to do it.) If you want to "unroot", just flash the unmodified boot file. (You could find a TWRP for the Nexus, and flash Magisk that way, but it would do the same thing.)
    mustang7757 likes this.
    12-20-2020 01:50 PM
  8. Cameron Dew1's Avatar
    thanks, at this point I actually thought I'd bricked it, I flashed it back to it's factory state, and it's updating and restoring all the files and photos and apps and that. i'll take note of what you said, so in the near future maybe i can try again, but really I'd only feel comfortable (or bothered) trying it again maybe if I knew more about rooting and the android system. are there any articles for that?

    also few Qs...
    will magik fix the "unable to mount system" problem?
    what exactly is busybox and why do I need it?
    are magik and busybox the only things I need for a root? do I need perma recovery as well?

    Cheers.
    12-20-2020 02:36 PM

Similar Threads

  1. Unlocked LG V60 with Dual Screen Case
    By mlee1999 in forum Marketplace Archive
    Replies: 7
    Last Post: 12-27-2020, 05:11 PM
  2. Can anyone on android pie help me with this please?
    By luap123 in forum Samsung Galaxy Note 9
    Replies: 2
    Last Post: 12-20-2020, 12:32 PM
  3. Replies: 2
    Last Post: 12-19-2020, 12:59 PM
  4. I want a reader/tablet just like my nexus!
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-19-2020, 12:29 PM
  5. Scanner App - Tips to scan documents and photos with ease
    By funfactor999 in forum Android Apps
    Replies: 1
    Last Post: 12-19-2020, 12:22 PM
LINK TO POST COPIED TO CLIPBOARD