1. Ondrej Rosypal's Avatar
    Hi all, having my 5X for about 3 weeks now and everything is copasetic, except one minor quibble.
    When checking my Google account from the computer, 5X shows in the device activity, but NOT in either the Device Manager or the Play store. It is not flagged as hidden in the settings either, it just ain't there. It's not a big deal as Google Play works just fine from the device but it does bug me a little. I've done some searching and the one solution that has been mentioned frequently was deleting the app data for Google Play services and rebooting the device. Not working out for me though, any otther ideas?
    12-03-2015 03:37 AM
  2. jleakey's Avatar
    Maybe try downloading the Android Device Manager app and see if that jump starts the process. I know it is supposed to be used to locate other devices but guess it couldn't hurt to try.

    https://play.google.com/store/apps/d...apps.adm&hl=en
    12-03-2015 07:31 AM
  3. Ondrej Rosypal's Avatar
    I do have it installed already, no cigar.
    12-03-2015 08:56 AM
  4. jleakey's Avatar
    Hmm I found someone else also had this issue and not only did they clear the Google Play Services cache but they also cleared download manager and Googles Services Framework. Their solution is listed below. Maybe give that a try.

    Clear data for the following apps:

    Play Store
    Download Manager
    Google Services Framework
    Restart your phone.

    Fire up the Play Store app.
    Wait for the device to show again on the web Play Store. It will appear under Settings > Devices. It may take a half-hour to several hours to appear.
    When your phone has shown up in the Play Store with the date registered as today's date, proceed with the next steps, but not before.

    Open Google Settings from your device's apps menu.
    Touch Android Device Manager.
    Uncheck Allow remote factory reset.
    Go to your device's main Settings menu, then touch Apps > All > Google Play services.
    Touch Clear Data. Note that this action doesn't remove personal data.
    Go back to Google Settings and select Allow remote factory reset.
    Restart your device.
    I would like to know exactly which of these steps was the magic sauce, but I'm content that it worked at all. I suppose that Play Store connection makes some sense, because while my phone was listed there, it showed a "Last Used" date back in March or somesuch.

    Link to the article I found. Under Answer 2
    Phone not appearing in Android Device Manager - Android Enthusiasts Stack Exchange
    12-03-2015 09:07 AM
  5. Ondrej Rosypal's Avatar
    Not sure what does Google Services Framework stand for but assuming it's Google Play Services, it's exactly what I have tried (including all the other steps) with no effect. Thanks for your effort though, it's appreciated.
    12-03-2015 10:24 AM
  6. jleakey's Avatar
    Google Services Framework is different from Google Play Services. It is found under all applications and on my phone it is 2 below Google Play Services. Not sure your wanting to jump through all those steps again, and quite frankly, not sure I would want to either. Anyway wish I could help more.
    12-03-2015 10:41 AM
  7. eaccentsac's Avatar
    Anyone ask about your location settings?

    Don't see your device? Make sure that you're signed in to your Google Account, location settings are on, and that you've turned on Android Device Manager in Google Settings.
    12-03-2015 12:07 PM
  8. Ondrej Rosypal's Avatar
    Okay, I purged the Google Services Framework data, which resulted in the Play Store on the device being completely unavailable.
    After a few hours playing with all sorts of possible solutions I was ready to give up and factory reset, but then I somehow managed to fix it going through several steps I found here and there in the forums and now (knock on wood) both the Play Store and the Device Manager see the 5X and everything works so well it almost scares me.
    Thanks guys!
    12-04-2015 03:31 AM
  9. jleakey's Avatar
    Glad it worked out for you. I had this same thing happen on a rooted device in the past but never really cared as it was an old device I only used for playing media.
    12-04-2015 08:52 AM

Similar Threads

  1. Can I unlock the phone with only fingerprint?
    By jiangqiushi in forum Nexus 6P
    Replies: 33
    Last Post: 05-28-2019, 10:19 AM
  2. Replies: 2
    Last Post: 12-03-2015, 10:13 AM
  3. Replies: 1
    Last Post: 12-03-2015, 04:21 AM
  4. Replies: 1
    Last Post: 12-03-2015, 03:14 AM
  5. Why aren't any radio stations functioning?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 12-03-2015, 01:46 AM
LINK TO POST COPIED TO CLIPBOARD