1. jo44jo's Avatar
    Is a service manual for the Nexus 5x available?

    Long story short, I was having a problem with my camera, so I whacked the phone on the palm of my hand a couple times (yeah, that might help! [lol]) and after that I lost the network and nothing I have tried has been able to bring it back. Maybe I somehow broke the network chip or connection with that whack?

    I am on T-Mobile running Android 7.1.1.

    I cleared the cache, tried different combo's of network settings (2G, 3G, 4G LTE), rebooted in safe mode, cleared the network settings, changed the SIM card, etc. Nothing has worked. I get Wi-fi but no T-Mobile network bars (the triangle is blank).

    I've opened the back of the phone previously to replace the glass (as a glass+frame module) and battery and everything worked fine after reassembly. So I am willing to reopen the case and poke around but I don't know what to poke at.

    So thinking that maybe a manual will help or else if anyone has any ideas/help they can offer, that would be super!
    01-26-2017 12:28 AM
  2. Tim1954's Avatar
    Maybe you broke the antenna. Google antenna in nexus etc and you should get a pic of where the antenna runs in the device.
    Try google service mode secret code for it and see if anything shows up in service mode first...
    01-27-2017 10:09 AM
  3. anon(10156028)'s Avatar
    I believe all the antennas are in the backing of the case. I would try removing and reattaching the backing after inspecting it for damage and making sure all everything visible is connected securely. There are a couple of snap connectors on the case backing near the camera that need to be tight in order for the antenna connectors to make contact. There's a good disassembly video here:
    Good luck!
    01-30-2017 10:34 PM
  4. jo44jo's Avatar
    What is this "secret code" thingy? How to access/interpret?

    I took your advice and looked at the antenna connections. I found that a couple of them were bent (see before photos at link). I straightened them out but that did not fix the problem. GPS and network still not functioning.

    Afraid I may need a new mainboard, sigh. Moral - don't smack your phone out of frustration!

    Before photos:
    https://drive.google.com/open?id=0B3...3ZaZGtTdWpqZjg
    01-31-2017 01:12 PM

Similar Threads

  1. why is my photo app using data on my new Moto z
    By Casey christian in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 01-26-2017, 06:57 AM
  2. My moto x play is not working properly
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-26-2017, 05:45 AM
  3. How can i unbrick my huawei p9, please help
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2017, 11:13 PM
  4. Had to reset my phone by removing the battery
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-25-2017, 10:48 PM
  5. Recurring expired text on my S3 Frontier
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-25-2017, 10:30 PM
LINK TO POST COPIED TO CLIPBOARD