1. mkilpatr's Avatar
    I want to scream! For the last couple of weeks I've been getting daily Google weather notifications in the top notification bar - signified by a small cloud symbol.

    I don't want this but I can't seem to get rid of it.

    I use Nova Launcher. Just now I activated Google Now as my home screen and rebooted, then found the "customise" option after swiping Google in from the left. I disabled the weather thing and then went back to Nova Launcher.

    And then I got another damned weather notification! Please, how I do tell this thing never to come back? It's infuriating.

    Michael
    Stephanie Randle likes this.
    11-06-2017 11:35 AM
  2. mkilpatr's Avatar
    Sorry for the duplicate, the website gave a strange error when I submitted the first time.
    11-06-2017 11:36 AM
  3. GSDer's Avatar
    You could try going to Settings -> Apps & notifications -> Notifications -> Notifications (with the bell symbol next to it) -> scroll down until you find News & Weather and select it -> set it to Off
    (Note that this is the navigation path on Oreo)
    11-06-2017 12:10 PM
  4. mkilpatr's Avatar
    Thanks, but unfortunately there are no "news" or "weather" or "news and weather" entries in my settings! I'm baffled by my inability to find online a set of instruction in which the steps actually make sense for my device and operating system. There are many pages of stuff if a google search for getting rid of weather notifications but nothing that tallies with what I see on my Nexus.

    My phone was recently updated to Android 8.0.0 with security patch level: 5 Oct 2017.
    11-06-2017 02:28 PM
  5. GSDer's Avatar
    Hmm. I could post pictures of each step that I listed above if that would help.
    I made mention of Oreo (8.0) because I'm pretty sure the steps are different on Nougat (7.x).
    11-06-2017 06:08 PM
  6. mkilpatr's Avatar
    Yesterday I tried again by activating Google Now as the home launcher and tried disabling any settings relatiing to weather before returning to Nova Launcher. This morning I have not yet had a weather notification so I'm holding my breath waiting to see what happens!

    M
    11-07-2017 04:00 AM
  7. GSDer's Avatar
    FWIW I turned off the News & Weather notification (that I documented above) but it doesn't make any difference - I still get that notification. Go figure.
    11-07-2017 01:29 PM
  8. GSDer's Avatar
    Ha! I think I've found the answer to your question.
    When that annoying notification is shown if you long-press it there should be an expanded view that's shown which will allow you to turn it off directly (along with any of the other Google notifications). See attached screenshots.
    badcat likes this.
    11-09-2017 10:31 AM
  9. ElDzsi's Avatar
    My question is how can I turn this function back?
    I am using Google Pixel 2XL with the latest update and July security patch also with the default launcher. I have turned on the Current weather condition in the Google app's notificaion menu but I still don't see the notification.
    Any idea?
    07-10-2018 03:00 PM
  10. Fayk's Avatar
    If you want Google notifications but not the weather notifications go onto the Weather app - Settings - Notifications - Your feed and disable the notification setting from there
    08-26-2018 03:00 AM

Similar Threads

  1. Replies: 18
    Last Post: 01-16-2018, 03:31 PM
  2. Fish out of water: Windows Phone to Android
    By MagusShadow in forum General News & Discussion
    Replies: 7
    Last Post: 11-28-2017, 09:45 AM
  3. Replies: 2
    Last Post: 11-06-2017, 01:26 PM
  4. I forgot my startup pin what should I do
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-06-2017, 11:25 AM
  5. Weather widget behavior lacking
    By messypotamia in forum Android Apps
    Replies: 1
    Last Post: 11-06-2017, 11:22 AM
LINK TO POST COPIED TO CLIPBOARD